summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/Shapely/Shapely-1.3.0.ebuild')
-rw-r--r--sci-libs/Shapely/Shapely-1.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/Shapely/Shapely-1.3.0.ebuild b/sci-libs/Shapely/Shapely-1.3.0.ebuild
new file mode 100644
index 000000000000..814952569578
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.1 2014/02/28 14:04:31 slis Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+} \ No newline at end of file