summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.6.1.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.6.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/hdf5/hdf5-1.6.1.ebuild b/sci-libs/hdf5/hdf5-1.6.1.ebuild
new file mode 100644
index 000000000000..96659169a867
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.6.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.1.ebuild,v 1.1 2004/12/28 20:55:37 ribosome Exp $
+
+DESCRIPTION="general purpose library and file format for storing scientific data"
+HOMEPAGE="http://hdf.ncsa.uiuc.edu/HDF5/"
+SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/current/src/${P}.tar.gz"
+
+LICENSE="NCSA-HDF"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~ia64 amd64"
+IUSE="static zlib ssl"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ #--disable-static conflicts with --enable-cxx, so we have to do either or
+ use static && myconf="--enable-cxx" || myconf="--disable-static"
+ use zlib || myconf="${myconf} --disable-zlib"
+ use ssl && myconf="${myconf} --with-ssl"
+
+ # NOTE: the hdf5 configure script has its own interpretation of
+ # the ARCH environment variable which conflicts with that of
+ # ebuild/emerge. As a work around, we save the ARCH variable as
+ # EBUILD_ARCH and restore it when we are done.
+ EBUILD_ARCH=${ARCH}
+ unset ARCH
+
+ ./configure ${myconf} --enable-linux-lfs --with-gnu-ld \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "configure failed"
+
+ # restore the ARCH environment variable
+ ARCH=${EBUILD_ARCH}
+
+ make || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc/${PF} \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+ dodoc README.txt COPYING MANIFEST
+ dohtml doc/html/*
+}