summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/nlopt/nlopt-1.2.ebuild')
-rw-r--r--sci-libs/nlopt/nlopt-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/nlopt/nlopt-1.2.ebuild b/sci-libs/nlopt/nlopt-1.2.ebuild
new file mode 100644
index 000000000000..ae1673e9df99
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-1.2.ebuild,v 1.1 2009/11/20 22:12:29 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Non-linear optimization library"
+SRC_URI="http://ab-initio.mit.edu/nlopt/${P}.tar.gz"
+HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+IUSE="octave cxx"
+
+DEPEND="octave? ( sci-mathematics/octave )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use octave; then
+ export OCT_INSTALL_DIR=/usr/libexec/octave/site/oct/${CHOST}
+ export M_INSTALL_DIR=/usr/share/octave/site/m
+ else
+ export MKOCTFILE=None
+ fi
+ econf \
+ --enable-shared \
+ $(use_with cxx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ for r in */README; do newdoc ${r} README.$(dirname ${r}); done
+}