summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/pari/pari-2.1.7.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.1.7.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sci-mathematics/pari/pari-2.1.7.ebuild b/sci-mathematics/pari/pari-2.1.7.ebuild
index 1dd11a83f0f9..6c1000791242 100644
--- a/sci-mathematics/pari/pari-2.1.7.ebuild
+++ b/sci-mathematics/pari/pari-2.1.7.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.7.ebuild,v 1.6 2006/02/02 15:23:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.7.ebuild,v 1.7 2007/11/16 15:46:32 markusle Exp $
inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
HOMEPAGE="http://pari.math.u-bordeaux.fr/"
-SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tgz"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/${PN}/unix/OLD/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,8 +17,8 @@ DEPEND="doc? ( virtual/tetex )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/docs.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/docs.patch
}
src_compile() {
@@ -71,14 +71,13 @@ src_compile() {
}
src_test() {
- cd ${S}
ebegin "Testing pari kernel"
make CFLAGS="-Wl,-lpari" test-kernel > /dev/null
eend $?
}
src_install() {
- make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
+ make DESTDIR="${D}" LIBDIR="${D}"/usr/$(get_libdir) install || die
if use emacs; then
insinto /usr/share/emacs/site-lisp
doins emacs/pari.el