summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/labplot/labplot-1.5.0.5.ebuild')
-rw-r--r--sci-visualization/labplot/labplot-1.5.0.5.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sci-visualization/labplot/labplot-1.5.0.5.ebuild b/sci-visualization/labplot/labplot-1.5.0.5.ebuild
index 24ef810f9a72..ee6612edcd4d 100644
--- a/sci-visualization/labplot/labplot-1.5.0.5.ebuild
+++ b/sci-visualization/labplot/labplot-1.5.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.5.0.5.ebuild,v 1.2 2006/04/13 19:14:46 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/labplot/labplot-1.5.0.5.ebuild,v 1.3 2006/04/30 14:02:25 carlo Exp $
inherit eutils gnuconfig kde
@@ -12,25 +12,25 @@ HOMEPAGE="http://labplot.sourceforge.net/"
SRC_URI="mirror://sourceforge/labplot/${MY_P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
SLOT="0"
-IUSE="audiofile cdf fftw imagemagick jpeg2k kexi opengl tiff"
+IUSE="cdf fftw imagemagick jpeg2k kexi opengl tiff"
-DEPEND=">=media-gfx/pstoedit-3.33
- >=sci-libs/gsl-1.4
+DEPEND=">=sci-libs/gsl-1.4
sci-libs/netcdf
virtual/ghostscript
>=x11-libs/qwtplot3d-0.2.6-r2
- audiofile? ( media-libs/audiofile )
+ media-libs/audiofile
fftw? ( >=sci-libs/fftw-3 )
imagemagick? ( >=media-gfx/imagemagick-5.5.6-r1 )
jpeg2k? ( >=media-libs/jasper-1.700.5-r1 )
tiff? ( >=media-libs/tiff-3.5.5 )
opengl? ( virtual/opengl )
kexi? ( || ( app-office/kexi app-office/koffice ) )
- !amd64? ( cdf? ( sci-libs/cdf ) )"
+ !amd64? ( cdf? ( sci-libs/cdf )
+ >=media-gfx/pstoedit-3.33 )"
-need-kde 3.1
+need-kde 3.4
src_unpack() {
kde_src_unpack
@@ -40,6 +40,7 @@ src_unpack() {
# let's make sure we don't use included libs
echo "# Using shared libs!" >| netcdf/netcdf.h
echo "# Using shared libs!" >| qwtplot3d/qwt3d_plot.h
+ echo "# Using shared libs!" >| audiofile/audiofile.h
}
src_compile() {
@@ -50,7 +51,7 @@ src_compile() {
# texvc not in Portage and I'm not keen maintaining it
# qsa ebuilds in bad shape atm.
local myconf="--disable-fftw --enable-gsl --enable-ps2eps \
- --disable-texvc --disable-ocaml --enable-netcdf \
+ --disable-texvc --disable-ocaml --enable-netcdf --enable-audiofile \
--enable-system-qwtplot3d --disable-qsa"
if use amd64; then
@@ -62,7 +63,6 @@ src_compile() {
local myconf="${myconf} \
$(use_enable fftw fftw3) \
$(use_enable imagemagick ImageMagick) \
- $(use_enable audiofile) \
$(use_enable jpeg2k jasper) \
$(use_enable tiff) \
$(use_enable kexi KexiDB) \