summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sg3_utils/sg3_utils-1.08.ebuild')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.08.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.08.ebuild b/sys-apps/sg3_utils/sg3_utils-1.08.ebuild
new file mode 100644
index 000000000000..2882b95e71d2
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.08.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.08.ebuild,v 1.1 2004/08/14 22:48:41 plasmaroo Exp $
+
+inherit eutils
+
+DESCRIPTION="Sg3_utils provide a collection of programs that use the sg SCSI interface"
+HOMEPAGE="http://www.torque.net/sg/"
+SRC_URI="http://www.torque.net/sg/p/${P}.tgz
+ http://www.garloff.de/kurt/linux/rescan-scsi-bus.sh"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-llseek.patch
+ sed -i "s:-O2:$CFLAGS:g" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${DISTDIR}/rescan-scsi-bus.sh || die 'Failed to install rescan-scsi-bus.sh!'
+ einstall INSTDIR=${D}/usr/bin MANDIR=${D}/usr/man || die 'Failed to install sg3_utils!'
+}