summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pambase/ChangeLog10
-rw-r--r--sys-auth/pambase/pambase-20090430.ebuild73
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index 182c1bb28e9e..c9881f6df281 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.65 2009/03/21 02:36:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.66 2009/04/30 16:28:52 flameeyes Exp $
+
+*pambase-20090430 (30 Apr 2009)
+
+ 30 Apr 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pambase-20090430.ebuild:
+ Add a new pambase version, with a stricter dependency on ConsoleKit and
+ support for remote sessions as well as local. Should fix bug #260842 (PAM
+ side).
21 Mar 2009; Jeroen Roovers <jer@gentoo.org> pambase-20081028.ebuild:
Stable for HPPA (bug #261595).
diff --git a/sys-auth/pambase/pambase-20090430.ebuild b/sys-auth/pambase/pambase-20090430.ebuild
new file mode 100644
index 000000000000..71dd9f8b9d36
--- /dev/null
+++ b/sys-auth/pambase/pambase-20090430.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20090430.ebuild,v 1.1 2009/04/30 16:28:52 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="PAM base configuration files"
+HOMEPAGE="http://www.gentoo.org/proj/en/base/pam/"
+SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug cracklib passwdqc consolekit gnome-keyring selinux mktemp ssh +sha512"
+RESTRICT="binchecks"
+
+RDEPEND="
+ || (
+ >=sys-libs/pam-0.99.9.0-r1
+ ( sys-auth/openpam
+ || ( sys-freebsd/freebsd-pam-modules sys-netbsd/netbsd-pam-modules )
+ )
+ )
+ cracklib? ( >=sys-libs/pam-0.99[cracklib] )
+ consolekit? ( >=sys-auth/consolekit-0.3[pam] )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.20[pam] )
+ selinux? ( >=sys-libs/pam-0.99[selinux] )
+ passwdqc? ( >=sys-auth/pam_passwdqc-1.0.4 )
+ mktemp? ( sys-auth/pam_mktemp )
+ ssh? ( sys-auth/pam_ssh )
+ sha512? ( >=sys-libs/pam-1.0.1 )
+ !<sys-freebsd/freebsd-pam-modules-6.2-r1
+ !<sys-libs/pam-0.99.9.0-r1"
+DEPEND=""
+
+src_compile() {
+ has_version sys-libs/pam && implementation="linux-pam"
+ has_version sys-auth/openpam && implementation="openpam"
+
+ emake \
+ GIT=true \
+ DEBUG=$(use debug && echo yes || echo no) \
+ CRACKLIB=$(use cracklib && echo yes || echo no) \
+ PASSWDQC=$(use passwdqc && echo yes || echo no) \
+ CONSOLEKIT=$(use consolekit && echo yes || echo no) \
+ GNOME_KEYRING=$(use gnome-keyring && echo yes || echo no) \
+ SELINUX=$(use selinux && echo yes || echo no) \
+ MKTEMP=$(use mktemp && echo yes || echo no) \
+ PAM_SSH=$(use ssh && echo yes || echo no) \
+ SHA512=$(use sha512 && echo yes || echo no) \
+ IMPLEMENTATION=${implementation} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake GIT=true DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ if use sha512; then
+ elog "Starting from version 20080801, pambase optionally enables"
+ elog "SHA512-hashed passwords. For this to work, you need sys-libs/pam-1.0.1"
+ elog "built against sys-libs/glibc-2.7 or later."
+ elog "If you don't have support for this, it will automatically fallback"
+ elog "to MD5-hashed passwords, just like before."
+ elog
+ elog "Please note that the change only affects the newly-changed passwords"
+ elog "and that SHA512-hashed passwords will not work on earlier versions"
+ elog "of glibc or Linux-PAM."
+ fi
+}