summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild')
-rw-r--r--sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild84
1 files changed, 50 insertions, 34 deletions
diff --git a/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild b/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild
index 470a71dc1bb3..362e3081925f 100644
--- a/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild
+++ b/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild
@@ -1,35 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild,v 1.3 2003/10/18 23:10:06 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.0_beta8.ebuild,v 1.4 2003/10/22 18:17:28 johnm Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
+#Original Kernel Version before Patches
+# eg: 2.6.0-test8
OKV=${PV/_beta/-test}
+OKV=${OKV/-r*//}
-PKV=${PF/_beta/-test}
-PKV=${PKV/-r/-bk}
-PKV=${PKV//${PN}-}
+#Kernel version after patches
+# eg: 2.6.0-test8-bk1
+KV=${PF/_beta/-test}
+KV=${KV/-r/-bk}
+KV=${KV//${PN}-}
-KV=${PV/_beta/-test}
-GPV=1
+#version of gentoo patchset
+# eg: 2.6.0-test8-r1-patchset-1
+# this gets added on right at the end before it links
+# if you dont want to apply these patches, set GPV=0
+GPV=0.1
-S=${WORKDIR}/linux-${PKV}
+S=${WORKDIR}/linux-${OKV}
ETYPE="sources"
IUSE="alsa"
DESCRIPTION="Full sources for the Development Branch of the Linux kernel"
-PATCH_URI=""
-# Uncomment for BitKeeper patches
-#PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${PKV}.bz2"
+[ ! ${GPV} == 0 ] && GPATCH_URI="mirror://gentoo/distfiles/genpatches-2.6-${GPV}.tar.bz2"
+[ -z ${KV/*-bk*/} ] && PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${KV}.bz2"
-
-GPATCH_URI="http://gentoo.oregonstate.edu/distfiles/genpatches-${PV}-${GPV}.tar.bz2"
-#GPATCH_URI="http://dev.gentoo.org/~brad_mssw/kernel_patches/2.6.0/genpatches-${PV}-${GPV}.tar.bz2"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 ${PATCH_URI} ${GPATCH_URI}"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
LICENSE="GPL-2"
-SLOT="${PKV}"
-KEYWORDS="-* ~x86 ~amd64"
+SLOT="${KV}"
+KEYWORDS="-* x86 ~amd64"
+
PROVIDE="virtual/linux-sources"
[ -n "$(use alsa)" ] && PROVIDE="${PROVIDE} virtual/alsa"
@@ -47,18 +52,32 @@ fi
src_unpack() {
cd ${WORKDIR}
unpack linux-${OKV}.tar.bz2
- unpack genpatches-${PV}-${GPV}.tar.bz2
- mv linux-${OKV} linux-${PKV}
- cd ${S}
-# Uncomment for BitKeeper Patches
-# epatch ${DISTDIR}/patch-${PKV}.bz2
-# Install gentoo-patches for the kernel
- for i in ${WORKDIR}/patches/* ; do
- epatch ${i}
- done
- rm -rf ${WORKDIR}/patches
+ # apply bk pulls
+ if [ -z ${KV/*-bk*/} ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/patch-${KV}.bz2
+ cd ${WORKDIR}
+ fi
+
+ # apply gentoo patches
+ if [ ! ${GPV} == 0 ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2
+ KV="${KV}-patchset-${GPV}"
+ cd ${WORKDIR}
+ fi
+ # move to appropriate src dir
+ if [ ! ${KV} == ${OKV} ]
+ then
+ mv linux-${OKV} linux-${KV}
+ S=${WORKDIR}/linux-${KV}
+ fi
+
+ cd ${S}
unset ARCH
#sometimes we have icky kernel symbols; this seems to get rid of them
make mrproper || die
@@ -104,18 +123,13 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${PKV} ${ROOT}/usr/src/linux-beta
- fi
+ [ ! -e ${ROOT}usr/src/linux-beta ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
echo
ewarn "Please note that ptyfs support has been removed from devfs"
- ewarn "in the later 2.5.x kernels, and you have to compile it in now,"
- ewarn "or else you will get errors when trying to open a pty."
- ewarn "The option is File systems->Pseudo filesystems->/dev/pts"
- ewarn "filesystem."
+ ewarn "and you have to compile it in now, or else you will get"
+ ewarn "errors when trying to open a pty. The option is:"
+ ewarn "File systems -> Pseudo filesystems -> /dev/pts filesystem."
echo
ewarn "Also, note that you must compile in support for"
ewarn "input devices (Input device support->Input devices),"
@@ -125,4 +139,6 @@ pkg_postinst() {
ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
ewarn "error."
echo
+ ewarn "PLEASE NOTE THIS IS NOT OFFICIALLY SUPPORTED BY GENTOO."
+ sleep 5
}