summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libstreams/libstreams-23.ebuild')
-rw-r--r--sys-libs/libstreams/libstreams-23.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libstreams/libstreams-23.ebuild b/sys-libs/libstreams/libstreams-23.ebuild
new file mode 100644
index 000000000000..65cd7be549e7
--- /dev/null
+++ b/sys-libs/libstreams/libstreams-23.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstreams/libstreams-23.ebuild,v 1.1 2004/11/07 19:02:03 kito Exp $
+
+DESCRIPTION="NeXT/Darwin Streams routines."
+HOMEPAGE="http://darwinsource.opendarwin.org/10.3.6/"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/Libstreams-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+
+SLOT="0"
+KEYWORDS="~ppc-macos"
+IUSE="debug"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/Libstreams-${PV}
+ sed -i -e 's:^NEXTSTEP_INSTALL_DIR = .*:NEXTSTEP_INSTALL_DIR = ${D}/usr/lib/system:' Makefile\
+ || die "sed failed"
+ sed -i -e 's:^PRIVATE_HDR_INSTALLDIR = .*:PRIVATE_HDR_INSTALLDIR = ${D}/usr/include:' Makefile.preamble\
+ || die "sed failed"
+}
+
+src_compile() {
+ emake RC_OS=macos || die "make failed"
+ emake profile || die "make profile failed"
+ if use debug; then
+ emake debug || die "make debug failed"
+ fi
+}
+
+src_install() {
+ into /usr/lib/system
+ dolib.a *.a
+
+ insinto /usr/include/streams
+ doins *.h
+} \ No newline at end of file