summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/ChangeLog6
-rw-r--r--www-apps/mythweb/mythweb-0.21_pre14151.ebuild25
2 files changed, 16 insertions, 15 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 3683fec87b70..d5357f94bed3 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.41 2007/08/14 18:53:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.42 2007/08/15 13:43:17 cardoe Exp $
+
+ 15 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
+ mythweb-0.21_pre14151.ebuild:
+ fixes after working with CharlieSu in #gentoo-mythtv
14 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
mythweb-0.21_pre14151.ebuild:
diff --git a/www-apps/mythweb/mythweb-0.21_pre14151.ebuild b/www-apps/mythweb/mythweb-0.21_pre14151.ebuild
index eeae73e1fc7d..dfea25304384 100644
--- a/www-apps/mythweb/mythweb-0.21_pre14151.ebuild
+++ b/www-apps/mythweb/mythweb-0.21_pre14151.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_pre14151.ebuild,v 1.2 2007/08/14 18:53:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_pre14151.ebuild,v 1.3 2007/08/15 13:43:17 cardoe Exp $
inherit mythtv webapp depend.php subversion
@@ -8,18 +8,14 @@ DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
IUSE=""
KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND="virtual/httpd-php
- dev-perl/DBI
+RDEPEND="dev-perl/DBI
dev-perl/DBD-mysql"
-S="${WORKDIR}/${PN}"
+need_php5_httpd
pkg_setup() {
webapp_pkg_setup
-
- if has_version 'dev-lang/php' ; then
- require_php_with_use session mysql pcre posix
- fi
+ require_php_with_use session mysql pcre posix
}
src_unpack() {
@@ -27,7 +23,7 @@ src_unpack() {
}
src_compile() {
- echo ""
+ :
}
src_install() {
@@ -37,14 +33,15 @@ src_install() {
dodir ${MY_HTDOCSDIR}/data
- cp -R ${S}/${PN}/[[:lower:]]* ${D}${MY_HTDOCSDIR}
- cp ${S}/${PN}/mythweb.conf.apache ${MY_SERVERCONFIGDIR}/
- cp ${S}/${PN}/mythweb.conf.lighttpd ${MY_SERVERCONFIGDIR}/
+ cp -R ${S}/[[:lower:]]* ${D}${MY_HTDOCSDIR}
+ cp ${S}/mythweb.conf.apache ${MY_SERVERCONFIGDIR}/
+ cp ${S}/mythweb.conf.lighttpd ${MY_SERVERCONFIGDIR}/
webapp_serverowned ${MY_HTDOCSDIR}/data
- webapp_configfile ${MY_SERVERCONFIGDIR}/mythweb.conf.apache
- webapp_configfile ${MY_SERVERCONFIGDIR}/mythweb.conf.lighttpd
+ # should these be uncommented?
+ #webapp_configfile ${MY_SERVERCONFIGDIR}/mythweb.conf.apache
+ #webapp_configfile ${MY_SERVERCONFIGDIR}/mythweb.conf.lighttpd
webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.21.txt