summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild')
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild
new file mode 100644
index 000000000000..76cbe085bf55
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.22.ebuild,v 1.1 2005/03/23 19:54:07 seemant Exp $
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}