summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/gnash/gnash-0.8.5.ebuild')
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index 2b73d87ea1f7..d35248afbdeb 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.3 2009/09/08 21:20:23 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.4 2009/09/09 10:17:48 mrpouet Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -118,7 +118,7 @@ src_prepare() {
eautoreconf
}
src_configure() {
- local myconf jobs
+ local myconf
local gui="sdl"
# Set nsplugin install directory.
use nsplugin && myconf="${myconf} --with-npapi-plugindir=/opt/netscape/plugins"
@@ -179,9 +179,12 @@ src_configure() {
${myconf}
}
src_install() {
- emake ${jobs} DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
# Install nsplugin in directory set by --with-npapi-plugindir.
- use nsplugin && emake DESTDIR="${D}" install-plugin || die "install plugins failed"
+ if use nsplugin; then
+ emake DESTDIR="${D}" install-plugin || die "install plugins failed"
+ fi
# Install kde konqueror plugin.
if use kde; then