summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/pango/pango-1.2.1-r1.ebuild')
-rw-r--r--x11-libs/pango/pango-1.2.1-r1.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/x11-libs/pango/pango-1.2.1-r1.ebuild b/x11-libs/pango/pango-1.2.1-r1.ebuild
index e77aafa19fcc..362393323910 100644
--- a/x11-libs/pango/pango-1.2.1-r1.ebuild
+++ b/x11-libs/pango/pango-1.2.1-r1.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.1-r1.ebuild,v 1.7 2003/07/19 23:36:01 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.1-r1.ebuild,v 1.8 2003/08/03 04:55:23 vapier Exp $
inherit eutils libtool
-IUSE="doc"
-SLOT="1"
-KEYWORDS="x86 ppc alpha ~sparc hppa amd64"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="Text rendering and Layout library"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
HOMEPAGE="http://www.pango.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+
LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="x86 ppc alpha ~sparc hppa amd64"
+IUSE="doc debug"
RDEPEND="virtual/x11
virtual/xft
>=dev-libs/glib-2.1.3
>=media-libs/freetype-2.1.2-r2"
# >=media-libs/fontconfig-2
-
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-0.9 )"
@@ -38,13 +36,11 @@ src_unpack() {
src_compile() {
elibtoolize
- local myconf=""
- use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
- if [ -n "$DEBUGBUILD" ]; then
- myconf="${myconf} --enable-debug"
- fi
-
- econf ${myconf} --without-qt || die
+ econf \
+ `use_enable doc gtk-doc` \
+ `use_enable debug` \
+ --without-qt \
+ || die
make || die "serial make failed"
}