summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/evolvotron/evolvotron-0.2.2.ebuild')
-rw-r--r--x11-misc/evolvotron/evolvotron-0.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.2.2.ebuild b/x11-misc/evolvotron/evolvotron-0.2.2.ebuild
new file mode 100644
index 000000000000..e662aa1ad4be
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.2.2.ebuild,v 1.1 2003/11/03 06:00:26 mr_bones_ Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="An interactive generative art application"
+HOMEPAGE="http://www.bottlenose.demon.co.uk/share/evolvotron/index.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-libs/qt-3"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e '/QMAKE_CXXFLAGS_RELEASE .*march/d' \
+ -e "/^QMAKE_CXXFLAGS_RELEASE += -O3/ s:=.*:= ${CXXFLAGS}:" \
+ -e '/^INSTALLPATH/ s:=.*:= /usr/bin:' ${S}/common.pro || \
+ die "sed common.pro failed"
+}
+
+src_compile() {
+ econf || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die "make install failed"
+ dodoc CHANGES README TODO || die "dodoc failed"
+}