summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbmail/ChangeLog8
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3.ebuild19
-rw-r--r--x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch89
3 files changed, 104 insertions, 12 deletions
diff --git a/x11-misc/bbmail/ChangeLog b/x11-misc/bbmail/ChangeLog
index be88d8a072b9..006ebfb87492 100644
--- a/x11-misc/bbmail/ChangeLog
+++ b/x11-misc/bbmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/bbmail
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbmail/ChangeLog,v 1.16 2008/09/22 12:52:50 omp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbmail/ChangeLog,v 1.17 2009/07/30 16:25:06 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> bbmail-0.9.3.ebuild,
+ +files/bbmail-0.9.3-gcc4.4.patch:
+ Fix building with GCC 4.4 and -Wl,--as-needed.
22 Sep 2008; David Shakaryan <omp@gentoo.org> metadata.xml:
Change herd from commonbox to desktop-wm.
diff --git a/x11-misc/bbmail/bbmail-0.9.3.ebuild b/x11-misc/bbmail/bbmail-0.9.3.ebuild
index a0f9393642fa..cb4a4c5ebf29 100644
--- a/x11-misc/bbmail/bbmail-0.9.3.ebuild
+++ b/x11-misc/bbmail/bbmail-0.9.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbmail/bbmail-0.9.3.ebuild,v 1.1 2008/09/17 21:16:31 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbmail/bbmail-0.9.3.ebuild,v 1.2 2009/07/30 16:25:06 ssuominen Exp $
-inherit eutils
+EAPI=2
+inherit autotools eutils
DESCRIPTION="blackbox mail notification"
HOMEPAGE="http://www.sourceforge.net/projects/bbtools"
@@ -13,18 +14,16 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND="
- virtual/blackbox
+RDEPEND="virtual/blackbox
x11-libs/libX11
x11-libs/libXext"
-
DEPEND="${RDEPEND}
x11-proto/xproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc4.3.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch \
+ "${FILESDIR}"/${P}-gcc4.4.patch
+ eautoreconf
}
src_install () {
diff --git a/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch
new file mode 100644
index 000000000000..d0f93d921d97
--- /dev/null
+++ b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch
@@ -0,0 +1,89 @@
+diff -ur bbmail-0.9.3.orig/configure.ac bbmail-0.9.3/configure.ac
+--- bbmail-0.9.3.orig/configure.ac 2007-12-03 23:04:11.000000000 +0200
++++ bbmail-0.9.3/configure.ac 2009-07-30 19:24:12.000000000 +0300
+@@ -9,13 +9,11 @@
+ AC_DEFUN(AC_SET_DEBUG,
+ [
+ test "$CXXFLAGS" = "" && CXXFLAGS="-g -Wall -DDEBUG"
+- test "$LDFLAGS" = "" && LDFLAGS=""
+ ])
+
+ AC_DEFUN(AC_SET_NODEBUG,
+ [
+- test "$CXXFLAGS" = "" && CXXFLAGS="-O2 -Wall"
+- test "$LDFLAGS" = "" && LDFLAGS="-s"
++ test "$CXXFLAGS" = "" && CXXFLAGS="-Wall"
+ ])
+
+
+@@ -46,9 +44,9 @@
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LIBS="$X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+ dnl Checks for Xextension
+diff -ur bbmail-0.9.3.orig/src/bbmail.cpp bbmail-0.9.3/src/bbmail.cpp
+--- bbmail-0.9.3.orig/src/bbmail.cpp 2007-12-03 23:08:26.000000000 +0200
++++ bbmail-0.9.3/src/bbmail.cpp 2009-07-30 19:20:10.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "config.h"
+ #include <string>
+diff -ur bbmail-0.9.3.orig/src/mailboxmenu.cpp bbmail-0.9.3/src/mailboxmenu.cpp
+--- bbmail-0.9.3.orig/src/mailboxmenu.cpp 2005-02-01 00:03:37.000000000 +0200
++++ bbmail-0.9.3/src/mailboxmenu.cpp 2009-07-30 19:20:39.000000000 +0300
+@@ -19,6 +19,9 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+ //
++
++#include <cstdio>
++
+ #include "mailboxmenu.h"
+
+ MailboxMenu::MailboxMenu(ToolWindow *toolwindow) :
+diff -ur bbmail-0.9.3.orig/src/main.cpp bbmail-0.9.3/src/main.cpp
+--- bbmail-0.9.3.orig/src/main.cpp 2006-01-20 23:28:08.000000000 +0200
++++ bbmail-0.9.3/src/main.cpp 2009-07-30 19:19:49.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "main.h"
+ #include "config.h"
+diff -ur bbmail-0.9.3.orig/src/Makefile.am bbmail-0.9.3/src/Makefile.am
+--- bbmail-0.9.3.orig/src/Makefile.am 2005-09-06 23:57:42.000000000 +0300
++++ bbmail-0.9.3/src/Makefile.am 2009-07-30 19:24:39.000000000 +0300
+@@ -10,5 +10,4 @@
+ spoollist.cpp spoollist.h \
+ mailboxmenu.cpp mailboxmenu.h \
+ blackboxstyle.h
+-bbmail_LDADD = @X_LIBS@
+-
++bbmail_LDADD = @LIBS@
+diff -ur bbmail-0.9.3.orig/src/resource.cpp bbmail-0.9.3/src/resource.cpp
+--- bbmail-0.9.3.orig/src/resource.cpp 2007-08-28 19:47:19.000000000 +0300
++++ bbmail-0.9.3/src/resource.cpp 2009-07-30 19:20:00.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "resource.h"
+ #include "blackboxstyle.h"