summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild28
1 files changed, 23 insertions, 5 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
index 926c9f8201b1..f68202870964 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild,v 1.2 2011/12/23 17:37:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild,v 1.3 2012/01/02 13:25:59 wired Exp $
EAPI="4"
@@ -15,8 +15,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
256-color alt-font-width afterimage blink +focused-urgency fading-colors
- +font-styles iso14755 +mousewheel +perl pixbuf startup-notification truetype
- unicode3 +vanilla wcwidth
+ +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
+ startup-notification truetype unicode3 +vanilla wcwidth
"
RDEPEND="
@@ -37,7 +37,7 @@ DEPEND="
x11-proto/xproto
"
-REQUIRED_USE="vanilla? ( !alt-font-width focused-urgency !wcwidth )"
+REQUIRED_USE="vanilla? ( !alt-font-width focused-urgency !secondary-wheel !wcwidth )"
src_prepare() {
# fix for prefix not installing properly
@@ -62,6 +62,12 @@ src_prepare() {
# bug #237271
epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
+ # support for wheel scrolling on secondary screens
+ use secondary-wheel && epatch "${FILESDIR}"/${P}-secondary-wheel.patch
+
+ # ctrl-l buffer fix
+ epatch "${FILESDIR}"/${P}-clear.patch
+
use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
fi
@@ -106,3 +112,15 @@ src_install() {
cd "${S}"/doc
dodoc README* changes.txt etc/* rxvt-tabbed
}
+
+pkg_postinst() {
+ if use secondary-wheel; then
+ elog "You have enabled the secondary-wheel USE flag."
+ elog "This allows you to scroll in secondary screens"
+ elog "(like mutt's message list/view) using the mouse wheel."
+ elog
+ elog "To actually enable the feature you have to add"
+ elog " URxvt*secondaryWheel: true"
+ elog "in your ~/.Xdefaults file"
+ fi
+}