summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xvt/xvt-2.1-r2.ebuild')
-rw-r--r--x11-terms/xvt/xvt-2.1-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/xvt/xvt-2.1-r2.ebuild b/x11-terms/xvt/xvt-2.1-r2.ebuild
new file mode 100644
index 000000000000..2d96bf3b4eb9
--- /dev/null
+++ b/x11-terms/xvt/xvt-2.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/xvt-2.1-r2.ebuild,v 1.1 2009/09/04 13:59:09 jer Exp $
+
+EAPI="2"
+
+inherit ccc eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A tiny vt100 terminal emulator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
+SRC_URI="ftp://ftp.x.org/R5contrib/xvt-1.0.tar.Z
+ mirror://gentoo/xvt-2.1.diff.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+S=${WORKDIR}/${PN}-1.0
+
+src_prepare() {
+ # this brings the distribution upto version 2.1
+ epatch "${WORKDIR}"/xvt-2.1.diff
+
+ # fix #61393
+ epatch "${FILESDIR}/xvt-ttyinit-svr4pty.diff"
+
+ # CFLAGS, CC #241554
+ epatch "${FILESDIR}/xvt-makefile.patch"
+
+ # int main, not void main
+ epatch "${FILESDIR}/xvt-int-main.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xvt || die "dobin failed"
+ doman xvt.1
+ dodoc README
+}