summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild')
-rw-r--r--xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild b/xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild
new file mode 100644
index 000000000000..3ff7dc2e4716
--- /dev/null
+++ b/xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4mcs/libxfce4mcs-4.0.0.ebuild,v 1.7 2004/03/16 04:13:51 bcowan Exp $
+
+IUSE="X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Libraries for XFCE4"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ia64 x86 ~ppc ~alpha ~sparc amd64 hppa"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README ChangeLog
+}