summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gypsy/gypsy-0.8.ebuild')
-rw-r--r--sci-geosciences/gypsy/gypsy-0.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-geosciences/gypsy/gypsy-0.8.ebuild b/sci-geosciences/gypsy/gypsy-0.8.ebuild
new file mode 100644
index 0000000..fa24dd3
--- /dev/null
+++ b/sci-geosciences/gypsy/gypsy-0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Gypsy is a GPS multiplexing daemon."
+HOMEPAGE="http://gypsy.freedesktop.org/wiki/"
+SRC_URI="http://gypsy.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="bluetooth"
+
+RDEPEND="sys-apps/dbus
+ dev-libs/glib:2
+ bluetooth? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf $(use_enable bluetooth )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}