summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'apps/dev-db/sqlite/files')
-rw-r--r--apps/dev-db/sqlite/files/digest-sqlite-3.3.133
-rw-r--r--apps/dev-db/sqlite/files/maketcllib.sh40
-rw-r--r--apps/dev-db/sqlite/files/sandbox-fix1.patch40
-rw-r--r--apps/dev-db/sqlite/files/sandbox-fix2.patch14
-rw-r--r--apps/dev-db/sqlite/files/sqlite-2.8.15-alignement-fix.patch12
-rw-r--r--apps/dev-db/sqlite/files/sqlite-2.8.16-multilib.patch108
-rw-r--r--apps/dev-db/sqlite/files/sqlite-3-test-fix-3.3.4.patch20
-rw-r--r--apps/dev-db/sqlite/files/sqlite-3.3.3-tcl-fix.patch22
-rw-r--r--apps/dev-db/sqlite/files/sqlite-64bit-test-fix.patch15
-rw-r--r--apps/dev-db/sqlite/files/sqlite-64bit-test-fix2.patch13
10 files changed, 0 insertions, 287 deletions
diff --git a/apps/dev-db/sqlite/files/digest-sqlite-3.3.13 b/apps/dev-db/sqlite/files/digest-sqlite-3.3.13
deleted file mode 100644
index a0eec1d..0000000
--- a/apps/dev-db/sqlite/files/digest-sqlite-3.3.13
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6b24d9c364215fba82242a86f54e0ad1 sqlite-3.3.13.tar.gz 2054971
-RMD160 5ed0c1248db4681349ee89a851fe200ea855fbcd sqlite-3.3.13.tar.gz 2054971
-SHA256 930144d92e91ef7b3a7edbbe768cc539db95c06cf05cb156350f8d35bb56625c sqlite-3.3.13.tar.gz 2054971
diff --git a/apps/dev-db/sqlite/files/maketcllib.sh b/apps/dev-db/sqlite/files/maketcllib.sh
deleted file mode 100644
index ad87ce1..0000000
--- a/apps/dev-db/sqlite/files/maketcllib.sh
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/bash
-#
-# This script was adapted from the one used by Hwaci to build it's
-# documentation and binaries for shipping to their website.
-#
-# Any similarity to the original has probably been trampled into
-# oblivion modifying everything for Gentoo.
-#
-echo "Starting TCL Build"
-
-# Set srcdir to the name of the directory that contains the publish.sh
-# script.
-#
-srcdir=`echo "$0" | sed 's%\(^.*\)/[^/][^/]*$%\1%'`
-
-#
-# Build the tclsqlite.so shared library for import into tclsh or wish
-# under Linux
-#
-make target_source
-source /etc/make.conf
-cd tsrc
-rm shell.c
-
-OPTS='-DUSE_TCL_STUBS=1 -DNDEBUG=1'
-TCLSTUBLIB=${TCL_BUILD_STUB_LIB_PATH}
-
-export CFLAGS
-gcc -fPIC $CFLAGS $OPTS -I. -shared *.c $TCLSTUBLIB -o tclsqlite.so
-
-strip tclsqlite.so
-cp tclsqlite.so ..
-
-cd ..
-
-echo "pkg_mkIndex [pwd] tclsqlite.so" >> make_pkgIndex.tcl
-tclsh make_pkgIndex.tcl
-
-echo "Done TCL Build"
-
diff --git a/apps/dev-db/sqlite/files/sandbox-fix1.patch b/apps/dev-db/sqlite/files/sandbox-fix1.patch
deleted file mode 100644
index 38e4256..0000000
--- a/apps/dev-db/sqlite/files/sandbox-fix1.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- test/capi3.test~ 2006-01-30 23:35:44.000000000 +0100
-+++ test/capi3.test 2006-02-05 19:41:12.000000000 +0100
-@@ -140,18 +140,6 @@
- do_test capi3-3.2 {
- sqlite3_close $db2
- } {SQLITE_OK}
--do_test capi3-3.3 {
-- catch {
-- set db2 [sqlite3_open /bogus/path/test.db {}]
-- }
-- sqlite3_errcode $db2
--} {SQLITE_CANTOPEN}
--do_test capi3-3.4 {
-- sqlite3_errmsg $db2
--} {unable to open database file}
--do_test capi3-3.5 {
-- sqlite3_close $db2
--} {SQLITE_OK}
- do_test capi3-3.6.1 {
- sqlite3_close $db2
- } {SQLITE_MISUSE}
-@@ -176,18 +164,6 @@
- do_test capi3-4.2 {
- sqlite3_close $db2
- } {SQLITE_OK}
--do_test capi3-4.3 {
-- catch {
-- set db2 [sqlite3_open16 [utf16 /bogus/path/test.db] {}]
-- }
-- sqlite3_errcode $db2
--} {SQLITE_CANTOPEN}
--do_test capi3-4.4 {
-- utf8 [sqlite3_errmsg16 $db2]
--} {unable to open database file}
--do_test capi3-4.5 {
-- sqlite3_close $db2
--} {SQLITE_OK}
- } ;# utf16
-
- # This proc is used to test the following API calls:
diff --git a/apps/dev-db/sqlite/files/sandbox-fix2.patch b/apps/dev-db/sqlite/files/sandbox-fix2.patch
deleted file mode 100644
index cf051c4..0000000
--- a/apps/dev-db/sqlite/files/sandbox-fix2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- test/attach3.test~ 2005-03-29 05:11:00.000000000 +0200
-+++ test/attach3.test 2006-02-05 19:30:45.000000000 +0100
-@@ -226,11 +226,6 @@
- # Failure to attach leaves us in a workable state.
- # Ticket #811
- #
--do_test attach3-11.0 {
-- catchsql {
-- ATTACH DATABASE '/nodir/nofile.x' AS notadb;
-- }
--} {1 {unable to open database: /nodir/nofile.x}}
- do_test attach3-11.1 {
- catchsql {
- ATTACH DATABASE ':memory:' AS notadb;
diff --git a/apps/dev-db/sqlite/files/sqlite-2.8.15-alignement-fix.patch b/apps/dev-db/sqlite/files/sqlite-2.8.15-alignement-fix.patch
deleted file mode 100644
index 7081ffd..0000000
--- a/apps/dev-db/sqlite/files/sqlite-2.8.15-alignement-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNr sqlite.orig/src/vdbeInt.h sqlite/src/vdbeInt.h
---- sqlite.orig/src/vdbeInt.h 2004-10-16 01:33:02.779442000 +0200
-+++ sqlite/src/vdbeInt.h 2004-10-16 01:35:01.139442000 +0200
-@@ -115,7 +115,7 @@
- int flags; /* Some combination of MEM_Null, MEM_Str, MEM_Dyn, etc. */
- double r; /* Real value */
- char *z; /* String value */
-- char zShort[NBFS]; /* Space for short strings */
-+ char zShort[NBFS] __attribute__ ((__aligned__(16))); /* Space for short strings */
- };
- typedef struct Mem Mem;
-
diff --git a/apps/dev-db/sqlite/files/sqlite-2.8.16-multilib.patch b/apps/dev-db/sqlite/files/sqlite-2.8.16-multilib.patch
deleted file mode 100644
index 3211187..0000000
--- a/apps/dev-db/sqlite/files/sqlite-2.8.16-multilib.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-diff -Naurp sqlite-2.8.16.orig/Makefile.in sqlite-2.8.16/Makefile.in
---- sqlite-2.8.16.orig/Makefile.in 2005-02-14 00:22:04.000000000 +0000
-+++ sqlite-2.8.16/Makefile.in 2005-02-17 18:22:50.174537727 +0000
-@@ -187,12 +187,12 @@ last_change: $(SRC)
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite.la: $(LIBOBJ)
-- $(LTLINK) -o libsqlite.la $(LIBOBJ) ${RELEASE} -rpath @exec_prefix@/lib \
-+ $(LTLINK) -o libsqlite.la $(LIBOBJ) ${RELEASE} -rpath @libdir@ \
- -version-info "8:6:8"
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LTLINK) -o libtclsqlite.la tclsqlite.lo \
-- libsqlite.la $(LIBTCL) -rpath @exec_prefix@/lib/sqlite \
-+ libsqlite.la $(LIBTCL) -rpath @libdir@/sqlite \
- -version-info "8:6:8"
-
- sqlite@TARGET_EXEEXT@: $(TOP)/src/shell.c libsqlite.la sqlite.h
-@@ -465,14 +465,14 @@ doc: $(DOC)
- mv $(DOC) doc
-
- install: sqlite libsqlite.la sqlite.h
-- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
-- $(LTINSTALL) libsqlite.la $(DESTDIR)$(exec_prefix)/lib
-+ $(INSTALL) -d $(DESTDIR)@libdir@
-+ $(LTINSTALL) libsqlite.la $(DESTDIR)@libdir@
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/bin
- $(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
- $(INSTALL) -d $(DESTDIR)$(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(DESTDIR)$(prefix)/include
-- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-- $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-+ $(INSTALL) -d $(DESTDIR)@libdir@/pkgconfig;
-+ $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)@libdir@/pkgconfig;
-
- clean:
- rm -f *.lo *.la *.o sqlite@TARGET_EXEEXT@ libsqlite.la sqlite.h opcodes.*
-diff -Naurp sqlite-2.8.16.orig/Makefile.linux-gcc sqlite-2.8.16/Makefile.linux-gcc
---- sqlite-2.8.16.orig/Makefile.linux-gcc 2005-02-14 00:22:04.000000000 +0000
-+++ sqlite-2.8.16/Makefile.linux-gcc 2005-02-17 18:21:47.654969648 +0000
-@@ -14,7 +14,7 @@
- #### The toplevel directory of the source tree. This is the directory
- # that contains this "Makefile.in" and the "configure.in" script.
- #
--TOP = ../sqlite
-+TOP = @@S@@
-
- #### C Compiler and options for use in building executables that
- # will run on the platform that is doing the build.
-@@ -38,8 +38,8 @@ THREADSAFE = -DTHREADSAFE=0
- #### Specify any extra linker options needed to make the library
- # thread safe
- #
--#THREADLIB = -lpthread
--THREADLIB =
-+THREADLIB = -lpthread
-+#THREADLIB =
-
- #### Leave MEMORY_DEBUG undefined for maximum speed. Use MEMORY_DEBUG=1
- # to check for memory leaks. Use MEMORY_DEBUG=2 to print a log of all
-@@ -64,7 +64,7 @@ EXE =
- # will run on the target platform. This is usually the same
- # as BCC, unless you are cross-compiling.
- #
--TCC = gcc -O6
-+TCC = @@CC@@ @@CFLAGS@@
- #TCC = gcc -g -O0 -Wall
- #TCC = gcc -g -O0 -Wall -fprofile-arcs -ftest-coverage
- #TCC = /opt/mingw/bin/i386-mingw32-gcc -O6
-@@ -72,23 +72,23 @@ TCC = gcc -O6
-
- #### Tools used to build a static library.
- #
--AR = ar cr
-+AR = @@AR@@ cr
- #AR = /opt/mingw/bin/i386-mingw32-ar cr
--RANLIB = ranlib
-+RANLIB = @@RANLIB@@
- #RANLIB = /opt/mingw/bin/i386-mingw32-ranlib
-
- #### Extra compiler options needed for programs that use the TCL library.
- #
--#TCL_FLAGS =
-+#TCL_FLAGS = @@TCL_FLAGS@@
- #TCL_FLAGS = -DSTATIC_BUILD=1
--TCL_FLAGS = -I/home/drh/tcltk/8.4linux
-+#TCL_FLAGS = -I/home/drh/tcltk/8.4linux
- #TCL_FLAGS = -I/home/drh/tcltk/8.4win -DSTATIC_BUILD=1
- #TCL_FLAGS = -I/home/drh/tcltk/8.3hpux
-
- #### Linker options needed to link against the TCL library.
- #
--#LIBTCL = -ltcl -lm -ldl
--LIBTCL = /home/drh/tcltk/8.4linux/libtcl8.4g.a -lm -ldl
-+LIBTCL = -ltcl -lm -ldl
-+#LIBTCL = /home/drh/tcltk/8.4linux/libtcl8.4g.a -lm -ldl
- #LIBTCL = /home/drh/tcltk/8.4win/libtcl84s.a -lmsvcrt
- #LIBTCL = /home/drh/tcltk/8.3hpux/libtcl8.3.a -ldld -lm -lc
-
-@@ -100,7 +100,7 @@ READLINE_FLAGS = -DHAVE_READLINE=1 -I/us
- #### Linker options needed by programs using readline() must link against.
- #
- #LIBREADLINE =
--LIBREADLINE = -static -lreadline -ltermcap
-+LIBREADLINE = -static -lreadline -lncurses
-
- #### Should the database engine assume text is coded as UTF-8 or iso8859?
- #
diff --git a/apps/dev-db/sqlite/files/sqlite-3-test-fix-3.3.4.patch b/apps/dev-db/sqlite/files/sqlite-3-test-fix-3.3.4.patch
deleted file mode 100644
index 5429fbb..0000000
--- a/apps/dev-db/sqlite/files/sqlite-3-test-fix-3.3.4.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.old 2006-02-13 15:20:42.000000000 +0100
-+++ Makefile.in 2006-02-13 15:21:02.000000000 +0100
-@@ -242,7 +242,7 @@
- # of the most recently modified source code file
- #
- last_change: $(SRC)
-- cat $(SRC) | grep '$$Id: ' | sort +4 | tail -1 \
-+ cat $(SRC) | grep '$$Id: ' | sort -k 5 | tail -1 \
- | $(NAWK) '{print $$5,$$6}' >last_change
-
- libsqlite3.la: $(LIBOBJ)
-@@ -338,7 +338,7 @@
- $(LTCOMPILE) -c opcodes.c
-
- opcodes.c: opcodes.h $(TOP)/mkopcodec.awk
-- sort -n -b +2 opcodes.h | $(NAWK) -f $(TOP)/mkopcodec.awk >opcodes.c
-+ sort -n -b -k 3 opcodes.h | $(NAWK) -f $(TOP)/mkopcodec.awk >opcodes.c
-
- opcodes.h: parse.h $(TOP)/src/vdbe.c $(TOP)/mkopcodeh.awk
- cat parse.h $(TOP)/src/vdbe.c | $(NAWK) -f $(TOP)/mkopcodeh.awk >opcodes.h
diff --git a/apps/dev-db/sqlite/files/sqlite-3.3.3-tcl-fix.patch b/apps/dev-db/sqlite/files/sqlite-3.3.3-tcl-fix.patch
deleted file mode 100644
index 2d4356d..0000000
--- a/apps/dev-db/sqlite/files/sqlite-3.3.3-tcl-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- tclinstaller.tcl.old 2006-02-05 21:44:20.000000000 +0100
-+++ tclinstaller.tcl 2006-02-05 21:49:50.000000000 +0100
-@@ -7,14 +7,17 @@
- set VERSION [lindex $argv 0]
- set LIBFILE .libs/libtclsqlite3[info sharedlibextension]
- if { ![info exists env(DESTDIR)] } { set env(DESTDIR) "" }
--set LIBDIR $env(DESTDIR)[lindex $auto_path 0]
-+if { ![info exists env(TCLLIBDIR)] } { set env(TCLLIBDIR) [lindex $auto_path 0] }
-+set LIBDIR $env(DESTDIR)$env(TCLLIBDIR)
-+set LIBDIR_INSTALL $env(TCLLIBDIR)
- set LIBNAME [file tail $LIBFILE]
- set LIB $LIBDIR/sqlite3/$LIBNAME
-+set LIB_INSTALL $LIBDIR_INSTALL/sqlite3/$LIBNAME
-
- file delete -force $LIBDIR/sqlite3
- file mkdir $LIBDIR/sqlite3
- set fd [open $LIBDIR/sqlite3/pkgIndex.tcl w]
--puts $fd "package ifneeded sqlite3 $VERSION \[list load $LIB sqlite3\]"
-+puts $fd "package ifneeded sqlite3 $VERSION \[list load $LIB_INSTALL sqlite3\]"
- close $fd
-
- # We cannot use [file copy] because that will just make a copy of
diff --git a/apps/dev-db/sqlite/files/sqlite-64bit-test-fix.patch b/apps/dev-db/sqlite/files/sqlite-64bit-test-fix.patch
deleted file mode 100644
index f121e52..0000000
--- a/apps/dev-db/sqlite/files/sqlite-64bit-test-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- test/printf.test~ 2005-12-19 18:31:01.000000000 +0100
-+++ test/printf.test 2006-02-05 18:12:33.000000000 +0100
-@@ -130,12 +130,6 @@
- sqlite3_mprintf_scaled {A double: %g} 1.0e307 100.0
- } {A double: NaN}
-
--do_test printf-8.1 {
-- sqlite3_mprintf_int {%u %u %u} 0x7fffffff 0x80000000 0xffffffff
--} {2147483647 2147483648 4294967295}
--do_test printf-8.2 {
-- sqlite3_mprintf_int {%lu %lu %lu} 0x7fffffff 0x80000000 0xffffffff
--} {2147483647 2147483648 4294967295}
- do_test printf-8.3 {
- sqlite3_mprintf_int64 {%llu %llu %llu} 2147483647 2147483648 4294967296
- } {2147483647 2147483648 4294967296}
diff --git a/apps/dev-db/sqlite/files/sqlite-64bit-test-fix2.patch b/apps/dev-db/sqlite/files/sqlite-64bit-test-fix2.patch
deleted file mode 100644
index 08d93f0..0000000
--- a/apps/dev-db/sqlite/files/sqlite-64bit-test-fix2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- test/types3.test~ 2006-01-21 15:32:32.000000000 +0100
-+++ test/types3.test 2006-02-05 18:14:04.000000000 +0100
-@@ -30,10 +30,6 @@
- set V [expr {1+2}]
- concat [tcl_variable_type V] [execsql {SELECT typeof(:V)}]
- } {int integer}
--do_test types3-1.3 {
-- set V [expr {1+123456789012345}]
-- concat [tcl_variable_type V] [execsql {SELECT typeof(:V)}]
--} {wideInt integer}
-
- # A double variable comes in as REAL
- do_test types3-1.4 {