summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-09-06 20:19:16 -0700
committerPatrick McLean <chutzpah@gentoo.org>2013-09-06 20:19:16 -0700
commitbf8cc04e0837d99f57a6b2b3a629cd590bcdd375 (patch)
tree94f19638928a4952f298943eb7dcfb056cb490b4
parentadd .gitignore file (diff)
downloadchutzpah-bf8cc04e0837d99f57a6b2b3a629cd590bcdd375.tar.gz
chutzpah-bf8cc04e0837d99f57a6b2b3a629cd590bcdd375.tar.bz2
chutzpah-bf8cc04e0837d99f57a6b2b3a629cd590bcdd375.zip
add 9999 for app-vim/airline
-rw-r--r--app-vim/airline/Manifest1
-rw-r--r--app-vim/airline/airline-9999.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
new file mode 100644
index 0000000..151c6e3
--- /dev/null
+++ b/app-vim/airline/Manifest
@@ -0,0 +1 @@
+EBUILD airline-9999.ebuild 843 SHA256 e22ac1c612a40177c196ebc8fb615c7726ac4670d14e8636e17570aeef98b5cb SHA512 ad38ee45a79d9de0db0cec796c31aeb3a0b9ad9be58b1fde32ce4bc5a97be9e12681473ce898d6873fffa27c8395dbc451a3d0dbeb52f4a7e0975cc07dcc5d43 WHIRLPOOL 81de56376ec4f2be97072f3656a8018c845a6486f1b7ebb2c88104c3f2d23fe377b5440fedf00f6fb549b99ce31e43a0967b30da8df008cc63f7a4752e2414b4
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
new file mode 100644
index 0000000..aace7a0
--- /dev/null
+++ b/app-vim/airline/airline-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/airline/airline-0.4.ebuild,v 1.1 2013/08/26 18:46:05 radhermit Exp $
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bling/vim-airline.git"
+ RESTRICT=mirror
+else
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/bling/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/bling/vim-airline/ http://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ [[ ${PV} != 9999 ]] && { rm LICENSE README* || die; }
+}