aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-12-09 12:43:26 -0800
committerDonnie Berkholz <dberkholz@gentoo.org>2008-12-09 12:43:26 -0800
commitaef11449f1a377f2e0876f5c06fa55e2e5a75346 (patch)
tree5fc2f39e12e38647a439c61dce2bb2653cca7ad4 /app-misc
parentlabyrinth: 0.4.1 is over on google code now. (diff)
downloaddberkholz-aef11449f1a377f2e0876f5c06fa55e2e5a75346.tar.gz
dberkholz-aef11449f1a377f2e0876f5c06fa55e2e5a75346.tar.bz2
dberkholz-aef11449f1a377f2e0876f5c06fa55e2e5a75346.zip
labyrinth: Add live version. Hacks galore!
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/labyrinth/Manifest1
-rw-r--r--app-misc/labyrinth/labyrinth-9999.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/labyrinth/Manifest b/app-misc/labyrinth/Manifest
index e5a25ce..ef65068 100644
--- a/app-misc/labyrinth/Manifest
+++ b/app-misc/labyrinth/Manifest
@@ -1,2 +1,3 @@
DIST labyrinth_0.4.1.tar.gz 553527 RMD160 0020a9a7d1a199d5946ded20420884c11668aa12 SHA1 88b2557f614736968ffa624dd5d08c5bdfb7f302 SHA256 3fafcbd622074eaa80710d7eb76849d5e9b1e36742f48110e2425eb760e2d53c
EBUILD labyrinth-0.4.1.ebuild 689 RMD160 e7b2e7965535d672982f4140a538648958244457 SHA1 c53ae41104be4c5c28c7a06c6fb737ffb577f61e SHA256 694ad01fa822ccb6d3eb99176f4e02a157c30164633cb76dc285f5e530b94b70
+EBUILD labyrinth-9999.ebuild 1280 RMD160 e0a81daa6025ece62b73d7c37e33891a6d89585e SHA1 ab20a58dabfe6616d6d8d9ce7e3aa966ed921008 SHA256 c9526fabed889adf0e4d8619331ab36827c769435972bdeccc21e9389eee8540
diff --git a/app-misc/labyrinth/labyrinth-9999.ebuild b/app-misc/labyrinth/labyrinth-9999.ebuild
new file mode 100644
index 0000000..5b488ed
--- /dev/null
+++ b/app-misc/labyrinth/labyrinth-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="http://labyrinth.googlecode.com/svn/trunk/"
+ESVN_BOOTSTRAP="AT_M4DIR=m4 eautoreconf"
+
+inherit gnome2 autotools subversion
+
+DESCRIPTION="Mind mapping tool for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/~dscorgie/labyrinth.html"
+#SRC_URI="http://labyrinth.googlecode.com/files/labyrinth_${PV}.tar.gz"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/python
+ >=x11-libs/gtk+-2.8.0
+ >=dev-python/pygtk-2.8.0
+ >=dev-python/pygobject-2.10
+ >=dev-python/gnome-python-2.12
+ >=gnome-base/gnome-desktop-2.14
+ >=dev-python/pycairo-1.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS Changelog NEWS README"
+
+src_unpack() {
+ subversion_fetch
+ sed -i \
+ -e "s:\(doc/Makefile\):\1\nhelp/Makefile:g" \
+ -e "s:\(GNOME_COMMON_INIT\):\1\nGNOME_DOC_INIT:g" \
+ "${S}"/configure.ac || die
+ sed -i \
+ -e "s:\(UndoManager.py\):\1 ResourceThought.py:g" \
+ "${S}"/src/Makefile.am || die
+ cd "${S}"
+ ln -s /usr/share/aclocal/gnome-doc-utils.m4 m4/ || die
+ ln -s /usr/share/gnome-doc-utils/gnome-doc-utils.make . || die
+ subversion_bootstrap
+ # copied from gnome2.eclass
+ gnome2_omf_fix
+ elibtoolize
+}