aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-01 18:37:12 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-01 18:37:12 -0700
commit0f65b7fd5c7e9cfc117e63c0c4b97fd48550bf50 (patch)
tree0a31e16a95c77d6f24864a5b58f25e916e1acb8f /dev-python
parentlm_sensors: merged to main tree. (diff)
downloaddberkholz-0f65b7fd5c7e9cfc117e63c0c4b97fd48550bf50.tar.gz
dberkholz-0f65b7fd5c7e9cfc117e63c0c4b97fd48550bf50.tar.bz2
dberkholz-0f65b7fd5c7e9cfc117e63c0c4b97fd48550bf50.zip
pycallgraph: bump to 0.4.1 from sunrise's 0.3.1.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycallgraph/ChangeLog12
-rw-r--r--dev-python/pycallgraph/Manifest4
-rw-r--r--dev-python/pycallgraph/metadata.xml5
-rw-r--r--dev-python/pycallgraph/pycallgraph-0.4.1.ebuild34
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pycallgraph/ChangeLog b/dev-python/pycallgraph/ChangeLog
new file mode 100644
index 0000000..6153f4d
--- /dev/null
+++ b/dev-python/pycallgraph/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-python/pycallgraph
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 19 Jun 2007; Ali Polatel (hawking) <polatel@gmail.com>
+ -pycallgraph-0.3.0.ebuild, +pycallgraph-0.3.1.ebuild:
+ version bump
+
+ 15 Mar 2007; Ali Polatel (hawking) <polatel@nerdshack.com>
+ +pycallgraph-0.3.0.ebuild, +metadata.xml:
+ New ebuild for bug 170806, thanks to Trevor Hardcastle
+
diff --git a/dev-python/pycallgraph/Manifest b/dev-python/pycallgraph/Manifest
new file mode 100644
index 0000000..11cc5d0
--- /dev/null
+++ b/dev-python/pycallgraph/Manifest
@@ -0,0 +1,4 @@
+DIST pycallgraph-0.4.1.tar.gz 13161 RMD160 1c2a294c78bf97e5a2479a1f5f02410a3a830fde SHA1 e3845765c602efb98d6a494966fe076ba82787b0 SHA256 185d838d290a07f2da5c59c71212d3c2e0648adaf8a0841be7ecb439b40bbb31
+EBUILD pycallgraph-0.4.1.ebuild 717 RMD160 188d0528b9701b28ab0c5ef28b7efe3b3310b5d7 SHA1 a2e4842cbc5c169240487e24874ea512bf616bfb SHA256 29165cae326f5daed80dcb43f6faf6cbf00ef812b9576c0c8648ad463de77f8b
+MISC ChangeLog 415 RMD160 3416a64fa5b3a6bf650c7a91788da94402d91c68 SHA1 632aafd050ddbe735d16a62ee2b15fff1a5d05cb SHA256 96561a9d9f790e4e3581e119a5342066f40a3f3707ddff4d5aab26be34191840
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pycallgraph/metadata.xml b/dev-python/pycallgraph/metadata.xml
new file mode 100644
index 0000000..7e32869
--- /dev/null
+++ b/dev-python/pycallgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-python/pycallgraph/pycallgraph-0.4.1.ebuild b/dev-python/pycallgraph/pycallgraph-0.4.1.ebuild
new file mode 100644
index 0000000..9ee5eae
--- /dev/null
+++ b/dev-python/pycallgraph/pycallgraph-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.3
+
+inherit distutils eutils
+
+DESCRIPTION="Python library that creates call graphs for Python programs."
+HOMEPAGE="http://pycallgraph.slowchop.com/"
+SRC_URI="http://${PN}.slowchop.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+
+ edos2unix "${D}"/usr/bin/*
+ sed -i \
+ -e '1 s:\(.*\):#!/usr/bin/env python\n\1:g' \
+ "${D}"/usr/bin/pycallgraph-dot.py \
+ || die
+}