aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-01 16:42:16 -0700
committerDonnie Berkholz <donnie@comet.(none)>2006-09-01 16:42:16 -0700
commit36c67d400c2a41a432c2e43a726ca8cebadc534b (patch)
tree4c3956b27980c4bab2b97804862deb96b90e5392 /dev-python
parentxorg-server: remove bad trailing backslash from libxf86config patch. (diff)
downloaddberkholz-36c67d400c2a41a432c2e43a726ca8cebadc534b.tar.gz
dberkholz-36c67d400c2a41a432c2e43a726ca8cebadc534b.tar.bz2
dberkholz-36c67d400c2a41a432c2e43a726ca8cebadc534b.zip
Add the first few deps required to get Red Hat's system-config-* stuff working.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyxf86config/Manifest8
-rw-r--r--dev-python/pyxf86config/files/digest-pyxf86config-0.3.303
-rw-r--r--dev-python/pyxf86config/pyxf86config-0.3.30.ebuild35
-rw-r--r--dev-python/rhpl/Manifest12
-rw-r--r--dev-python/rhpl/files/0.188-use-raw-strings-for-gettext.diff28
-rw-r--r--dev-python/rhpl/files/digest-rhpl-0.1883
-rw-r--r--dev-python/rhpl/rhpl-0.188.ebuild45
7 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/pyxf86config/Manifest b/dev-python/pyxf86config/Manifest
new file mode 100644
index 0000000..6b3ac2a
--- /dev/null
+++ b/dev-python/pyxf86config/Manifest
@@ -0,0 +1,8 @@
+DIST pyxf86config-0.3.30-1.fc6.src.rpm 338814 RMD160 9e13df300eb454b0cdd6e7782a908ebaf1cd523e SHA1 c02a535fed6e1256984960a9e14927a3267f749f SHA256 1ebd34e6832fa660fcfd34e22239c95331db3577d99e86a551a6e433315b2026
+EBUILD pyxf86config-0.3.30.ebuild 846 RMD160 b6059ff4185b12b1443b57706399ce01eadc8e2a SHA1 9535eccc6711344b8a6feb6eb166772e69349ea1 SHA256 d15f8963eeb43e373d32fbdb0a01733bb12663218775585285aae4515c2d6a3a
+MD5 50fd8cb05ae2891223c57cc3eaf5b623 pyxf86config-0.3.30.ebuild 846
+RMD160 b6059ff4185b12b1443b57706399ce01eadc8e2a pyxf86config-0.3.30.ebuild 846
+SHA256 d15f8963eeb43e373d32fbdb0a01733bb12663218775585285aae4515c2d6a3a pyxf86config-0.3.30.ebuild 846
+MD5 313abcbd0c3e553a97e926cbec123b11 files/digest-pyxf86config-0.3.30 280
+RMD160 52d14fbb8b65a58636bf986fe1289983cbc1e8f5 files/digest-pyxf86config-0.3.30 280
+SHA256 32e090781230f98ca46fea120a7d761eb686f78685ed25d7b6a7521288665922 files/digest-pyxf86config-0.3.30 280
diff --git a/dev-python/pyxf86config/files/digest-pyxf86config-0.3.30 b/dev-python/pyxf86config/files/digest-pyxf86config-0.3.30
new file mode 100644
index 0000000..fce2285
--- /dev/null
+++ b/dev-python/pyxf86config/files/digest-pyxf86config-0.3.30
@@ -0,0 +1,3 @@
+MD5 dbec4de5c2efcdefbac787f9d4c92bb2 pyxf86config-0.3.30-1.fc6.src.rpm 338814
+RMD160 9e13df300eb454b0cdd6e7782a908ebaf1cd523e pyxf86config-0.3.30-1.fc6.src.rpm 338814
+SHA256 1ebd34e6832fa660fcfd34e22239c95331db3577d99e86a551a6e433315b2026 pyxf86config-0.3.30-1.fc6.src.rpm 338814
diff --git a/dev-python/pyxf86config/pyxf86config-0.3.30.ebuild b/dev-python/pyxf86config/pyxf86config-0.3.30.ebuild
new file mode 100644
index 0000000..81a42a9
--- /dev/null
+++ b/dev-python/pyxf86config/pyxf86config-0.3.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="6"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Python wrappers for libxf86config"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="=dev-libs/glib-2*
+ dev-lang/python"
+DEPEND="${RDEPEND}
+ x11-base/xorg-server"
+
+src_compile() {
+ python_version
+ econf \
+ --with-python-version=${PYVER} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-python/rhpl/Manifest b/dev-python/rhpl/Manifest
new file mode 100644
index 0000000..a5476e6
--- /dev/null
+++ b/dev-python/rhpl/Manifest
@@ -0,0 +1,12 @@
+AUX 0.188-use-raw-strings-for-gettext.diff 1104 RMD160 1c6c7ac9fd93d83a8d4dc23bf02f22de3f46da54 SHA1 077adb46c0deceb0c74c8a4ff9675c1ca5b54a2f SHA256 f1e9c647b19f5bb3d570b3900607df66474939c2e9618b63ced0eed476042be8
+MD5 6d40b11098fae8adab17a48d650a57cf files/0.188-use-raw-strings-for-gettext.diff 1104
+RMD160 1c6c7ac9fd93d83a8d4dc23bf02f22de3f46da54 files/0.188-use-raw-strings-for-gettext.diff 1104
+SHA256 f1e9c647b19f5bb3d570b3900607df66474939c2e9618b63ced0eed476042be8 files/0.188-use-raw-strings-for-gettext.diff 1104
+DIST rhpl-0.188-2.src.rpm 299535 RMD160 a5ab8e57f10c25547877d528599ca4d3b2a3fdc8 SHA1 a14b83ccc0720bf0a556b6fed57389294ee1bf5e SHA256 87db85b3dd8ded08fe8fde548cedc28cd59a51c7dd5ec4b84d6881a332c014fd
+EBUILD rhpl-0.188.ebuild 1046 RMD160 72bcd1178d9b17f4a5b6ea62c1b068ec55114702 SHA1 9dca828463c759bd4084a25da4fd12ca53e3b278 SHA256 25bf4fd87b94d35dfeda569fb2cd778a25e6d7227eae5e0d4f5eeb989a15173d
+MD5 40d748d71b10b5acc2790dead2df1edf rhpl-0.188.ebuild 1046
+RMD160 72bcd1178d9b17f4a5b6ea62c1b068ec55114702 rhpl-0.188.ebuild 1046
+SHA256 25bf4fd87b94d35dfeda569fb2cd778a25e6d7227eae5e0d4f5eeb989a15173d rhpl-0.188.ebuild 1046
+MD5 cec94e56b1d67d1c5b725a53b4128215 files/digest-rhpl-0.188 241
+RMD160 a9cf3e1ad57a8a4b9a0638cd5533eba1eb862127 files/digest-rhpl-0.188 241
+SHA256 b954bd502e1c5d3e191e445969462db0da5c63500891bec1c325152a8b19ce27 files/digest-rhpl-0.188 241
diff --git a/dev-python/rhpl/files/0.188-use-raw-strings-for-gettext.diff b/dev-python/rhpl/files/0.188-use-raw-strings-for-gettext.diff
new file mode 100644
index 0000000..c388c52
--- /dev/null
+++ b/dev-python/rhpl/files/0.188-use-raw-strings-for-gettext.diff
@@ -0,0 +1,28 @@
+diff -ur -x '*.po' rhpl-0.188.orig/src/gzread.py rhpl-0.188/src/gzread.py
+--- rhpl-0.188.orig/src/gzread.py 2002-05-22 15:07:45.000000000 -0700
++++ rhpl-0.188/src/gzread.py 2006-09-01 16:20:01.000000000 -0700
+@@ -57,7 +57,7 @@
+
+ def _read_gzip_header(self):
+ magic = self.fileobj.read(2)
+- if magic != '\037\213':
++ if magic != r'\037\213':
+ self._unread(magic)
+ self.compressed = 0
+ return
+Only in rhpl-0.188/src/iconvmodule: build
+Only in rhpl-0.188/src/iconvmodule: iconv.so
+Only in rhpl-0.188/src: _translate.o
+diff -ur -x '*.po' rhpl-0.188.orig/src/translate.py rhpl-0.188/src/translate.py
+--- rhpl-0.188.orig/src/translate.py 2005-07-06 11:40:10.000000000 -0700
++++ rhpl-0.188/src/translate.py 2006-09-01 16:20:24.000000000 -0700
+@@ -125,7 +125,7 @@
+ buf = f.read(2)
+ f.close()
+
+- if buf == "\037\213":
++ if buf == r"\037\213":
+ mofile = gzip.open(file_path)
+ else:
+ mofile = open(file_path)
+Only in rhpl-0.188/src: _translate.so
diff --git a/dev-python/rhpl/files/digest-rhpl-0.188 b/dev-python/rhpl/files/digest-rhpl-0.188
new file mode 100644
index 0000000..916ee5b
--- /dev/null
+++ b/dev-python/rhpl/files/digest-rhpl-0.188
@@ -0,0 +1,3 @@
+MD5 5a74ee9e43760ea63669a27d171b7ec7 rhpl-0.188-2.src.rpm 299535
+RMD160 a5ab8e57f10c25547877d528599ca4d3b2a3fdc8 rhpl-0.188-2.src.rpm 299535
+SHA256 87db85b3dd8ded08fe8fde548cedc28cd59a51c7dd5ec4b84d6881a332c014fd rhpl-0.188-2.src.rpm 299535
diff --git a/dev-python/rhpl/rhpl-0.188.ebuild b/dev-python/rhpl/rhpl-0.188.ebuild
new file mode 100644
index 0000000..8dcb570
--- /dev/null
+++ b/dev-python/rhpl/rhpl-0.188.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib python rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="2"
+
+DESCRIPTION="Library of python code used by Red Hat Linux programs"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ dev-python/pyxf86config
+ !<sys-libs/libkudzu-1.2"
+DEPEND="${RDEPEND}
+ !s390? ( >=net-wireless/wireless-tools-28 )
+ sys-devel/gettext"
+
+src_unpack() {
+ rpm_src_unpack
+ epatch "${FILESDIR}"/${PV}-use-raw-strings-for-gettext.diff
+}
+
+src_compile() {
+ python_version
+ emake \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ ARCH=${ARCH} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON=python${PYVER} \
+ LIBDIR=$(get_libdir) \
+ install || die "emake install failed"
+}