summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-01-08 20:46:06 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-08 20:53:46 +0100
commit10bf422bcbe32d1d10bb619b30ed64f2c9258dee (patch)
treec7515fac0a55212f7b41a156f59b5e17429aa532
parentwww-apps/pydio: version bump 6.2.2 → 6.4.2 (diff)
downloadeva-10bf422bcbe32d1d10bb619b30ed64f2c9258dee.tar.gz
eva-10bf422bcbe32d1d10bb619b30ed64f2c9258dee.tar.bz2
eva-10bf422bcbe32d1d10bb619b30ed64f2c9258dee.zip
www-apps/pydio: fix htaccess for use with Apache 2.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Manifest-Sign-Key: C6085806
-rw-r--r--www-apps/pydio/pydio-6.4.2-r1.ebuild (renamed from www-apps/pydio/pydio-6.4.2.ebuild)13
1 files changed, 13 insertions, 0 deletions
diff --git a/www-apps/pydio/pydio-6.4.2.ebuild b/www-apps/pydio/pydio-6.4.2-r1.ebuild
index 66e9495..b6b32c2 100644
--- a/www-apps/pydio/pydio-6.4.2.ebuild
+++ b/www-apps/pydio/pydio-6.4.2-r1.ebuild
@@ -22,6 +22,19 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${PN}-core-${PV}"
+src_prepare() {
+ default
+
+ # Fix compatibility with Apache 2.4
+ while read htaccess ; do
+ LC_ALL=C sed -i \
+ -e 's/^[Dd]eny from all/Require all denied/' \
+ -e 's/^[Aa]llow from all/Require all granted/' \
+ -e '/^Order /d' \
+ "${htaccess}"
+ done < <(find "${S}" -name ".htaccess")
+}
+
src_install() {
webapp_src_preinst