summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2023-03-17 13:54:37 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2023-03-17 13:54:37 +0100
commit57d19aa97115341fdab2b0dfad9aaa52948a4887 (patch)
treed7a39056e0a5de30f0c32515936e673af0cd6fe5
parentdev-python/pre_commit: superseded by package in gentoo repository (diff)
downloadeva-57d19aa97115341fdab2b0dfad9aaa52948a4887.tar.gz
eva-57d19aa97115341fdab2b0dfad9aaa52948a4887.tar.bz2
eva-57d19aa97115341fdab2b0dfad9aaa52948a4887.zip
app-office/gnucash: bump to 4.13
Fixes segfault in OFX import in 4.12. See https://github.com/Gnucash/gnucash/pull/1472. Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--app-office/gnucash/Manifest1
-rw-r--r--app-office/gnucash/files/gnucash-3.8-examples-subdir.patch10
-rw-r--r--app-office/gnucash/files/gnucash-3.8-exclude-license.patch32
-rw-r--r--app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch26
-rw-r--r--app-office/gnucash/files/gnucash-4.12-fix-test.patch20
-rw-r--r--app-office/gnucash/gnucash-4.13.ebuild219
-rw-r--r--app-office/gnucash/metadata.xml39
7 files changed, 347 insertions, 0 deletions
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
new file mode 100644
index 0000000..55cde84
--- /dev/null
+++ b/app-office/gnucash/Manifest
@@ -0,0 +1 @@
+DIST gnucash-4.13.tar.bz2 14658572 BLAKE2B 027151a800194b854ad8bbe5175b24c99e924331f2b0a35745870542c2ade1e7347d2cbc3e400f621c6b5c1bb708633609a1891e729f8923d0c717537f884ca9 SHA512 7f1f5a6c6e537aca7e88c806461c58e90256954842026d801dba48586fa5817519220f532b9e460bc34751c94e6be4a80aac06325b7bada716616a735e2de3d3
diff --git a/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch b/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch
new file mode 100644
index 0000000..b271be8
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch
@@ -0,0 +1,10 @@
+--- a/doc/examples/CMakeLists.txt
++++ b/doc/examples/CMakeLists.txt
+@@ -21,6 +21,6 @@
+ web.qif
+ )
+
+-install(FILES ${examples_DATA} DESTINATION ${CMAKE_INSTALL_DOCDIR})
++install(FILES ${examples_DATA} DESTINATION ${CMAKE_INSTALL_DOCDIR}/examples)
+
+ set_dist_list(examples_DIST ${examples_DATA} CMakeLists.txt )
diff --git a/app-office/gnucash/files/gnucash-3.8-exclude-license.patch b/app-office/gnucash/files/gnucash-3.8-exclude-license.patch
new file mode 100644
index 0000000..553fb2a
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.8-exclude-license.patch
@@ -0,0 +1,32 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -660,7 +660,6 @@
+ ChangeLog.2018
+ DOCUMENTERS
+ HACKING
+- LICENSE
+ NEWS
+ README.dependencies
+ )
+@@ -932,21 +931,6 @@
+ )
+ endif()
+
+-#Link LICENSE to COPYING so that people expecting to find it,
+-#will. COPYING is normally linked by autogen.sh to the latest
+-#automake-provided version.
+-set (_CMD create_symlink)
+-if (WIN32)
+- set(_CMD copy)
+-endif()
+-
+-install(CODE
+-" execute_process(
+- COMMAND ${CMAKE_COMMAND} -E ${_CMD} LICENSE COPYING
+- WORKING_DIRECTORY ${CMAKE_INSTALL_DOCDIR}
+- )"
+-)
+-
+ #For windows, copy in some DLLs from Mingw
+
+ if (WIN32)
diff --git a/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch b/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch
new file mode 100644
index 0000000..970d423
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-4.12-drop-broken-test.patch
@@ -0,0 +1,26 @@
+https://github.com/Gnucash/gnucash/pull/1472
+
+From a52795b022e040d7a93bb4dc352780d832c55390 Mon Sep 17 00:00:00 2001
+From: Marco Scardovi <mscardovi@icloud.com>
+Date: Sat, 26 Nov 2022 22:38:02 +0100
+Subject: [PATCH] Fix test
+
+Signed-off-by: Marco Scardovi <mscardovi@icloud.com>
+--- a/libgnucash/core-utils/test/CMakeLists.txt
++++ b/libgnucash/core-utils/test/CMakeLists.txt
+@@ -19,9 +19,6 @@ endmacro()
+ add_core_utils_test(test-gnc-glib-utils test-gnc-glib-utils.c)
+ add_core_utils_test(test-resolve-file-path test-resolve-file-path.c)
+ add_core_utils_test(test-userdata-dir test-userdata-dir.c)
+-if (NOT MAC_INTEGRATION AND NOT WIN32)
+- add_core_utils_test(test-userdata-dir-invalid-home test-userdata-dir-invalid-home.c)
+-endif()
+ if (MAC_INTEGRATION)
+ target_compile_options(test-userdata-dir PRIVATE ${OSX_EXTRA_COMPILE_FLAGS})
+ target_compile_definitions(test-userdata-dir PRIVATE ${GTK_MAC_CFLAGS_OTHER})
+@@ -53,4 +50,4 @@ gnc_add_test(test-gnc-path-util "${test_gnc_path_util_SOURCES}"
+
+ set_dist_list(test_core_utils_DIST CMakeLists.txt
+ test-gnc-glib-utils.c test-resolve-file-path.c test-userdata-dir.c
+- test-userdata-dir-invalid-home.c gtest-path-utilities.cpp)
++ gtest-path-utilities.cpp)
diff --git a/app-office/gnucash/files/gnucash-4.12-fix-test.patch b/app-office/gnucash/files/gnucash-4.12-fix-test.patch
new file mode 100644
index 0000000..03b4bba
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-4.12-fix-test.patch
@@ -0,0 +1,20 @@
+https://github.com/Gnucash/gnucash/pull/1472
+
+From 6fe2028bca49f455b7841d178a712baec8f72919 Mon Sep 17 00:00:00 2001
+From: Marco Scardovi <mscardovi@icloud.com>
+Date: Thu, 24 Nov 2022 23:20:07 +0100
+Subject: [PATCH] Fix test
+
+Signed-off-by: Marco Scardovi <mscardovi@icloud.com>
+--- a/libgnucash/engine/mocks/fake-qofquery.cpp
++++ b/libgnucash/engine/mocks/fake-qofquery.cpp
+@@ -59,8 +59,8 @@ static class QofFakeQueryPool
+ {
+ ASSERT_TRUE(query_used((QofQuery*)query));
+ auto it = std::find(m_queriesUsed.begin(), m_queriesUsed.end(), query);
+- m_queriesUsed.erase(it);
+ m_queriesConsumed.push_back(*it);
++ m_queriesUsed.erase(it);
+ }
+
+ /* Remove a formerly added QofFakeQueryObject from the pool */
diff --git a/app-office/gnucash/gnucash-4.13.ebuild b/app-office/gnucash/gnucash-4.13.ebuild
new file mode 100644
index 0000000..c5bf640
--- /dev/null
+++ b/app-office/gnucash/gnucash-4.13.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump with app-doc/gnucash-docs
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A personal finance manager"
+HOMEPAGE="https://www.gnucash.org/"
+SRC_URI="https://github.com/Gnucash/gnucash/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 ~riscv x86"
+
+IUSE="aqbanking debug doc examples gnome-keyring +gui mysql nls ofx postgres python quotes register2 smartcard sqlite test"
+RESTRICT="!test? ( test )"
+
+# Examples doesn't build unless GUI is also built
+REQUIRED_USE="
+ examples? ( gui )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ smartcard? ( aqbanking )
+"
+
+# dev-libs/boost must always be built with nls enabled.
+# net-libs/aqbanking dropped gtk with v6. So, to simplify the
+# dependency, we just rely on that.
+RDEPEND="
+ >=dev-libs/glib-2.56.1:2
+ >=dev-scheme/guile-2.2.0:=[regex]
+ >=sys-libs/zlib-1.1.4
+ dev-libs/boost:=[icu,nls]
+ dev-libs/icu:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ aqbanking? (
+ >=net-libs/aqbanking-6[ofx?]
+ >=sys-libs/gwenhywfar-4.20.0:=
+ smartcard? ( sys-libs/libchipcard )
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.18 )
+ gui? (
+ >=x11-libs/gtk+-3.22.30:3
+ gnome-base/dconf
+ net-libs/webkit-gtk:4=
+ aqbanking? ( sys-libs/gwenhywfar:=[gtk] )
+ )
+ mysql? (
+ dev-db/libdbi
+ dev-db/libdbi-drivers[mysql]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.12:= )
+ postgres? (
+ dev-db/libdbi
+ dev-db/libdbi-drivers[postgres]
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ )
+ quotes? (
+ >=dev-perl/Finance-Quote-1.11
+ dev-perl/Date-Manip
+ dev-perl/HTML-TableExtract
+ )
+ sqlite? (
+ dev-db/libdbi
+ dev-db/libdbi-drivers[sqlite]
+ )
+"
+
+# gtest is a required dep
+# see https://bugs.gnucash.org/show_bug.cgi?id=795250
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/gettext-0.20
+ dev-lang/perl
+ dev-perl/XML-Parser
+ sys-devel/libtool
+ >=dev-cpp/gtest-1.8.0
+"
+BDEPEND="
+ dev-lang/swig
+ >=dev-util/cmake-3.10
+ virtual/pkgconfig
+"
+PDEPEND="
+ doc? (
+ ~app-doc/gnucash-docs-${PV}
+ gnome-extra/yelp
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.8-examples-subdir.patch"
+ "${FILESDIR}/${PN}-3.8-exclude-license.patch"
+)
+
+# guile generates ELF files without use of C or machine code
+# It's a portage false positive, bug #677600
+QA_PREBUILT='*[.]go'
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # Fix tests writing to /tmp
+ local fixtestfiles=(
+ gnucash/report/test/test-report-html.scm
+ gnucash/report/reports/standard/test/test-invoice.scm
+ gnucash/report/reports/standard/test/test-new-owner-report.scm
+ gnucash/report/reports/standard/test/test-owner-report.scm
+ gnucash/report/reports/standard/test/test-transaction.scm
+ gnucash/report/reports/standard/test/test-portfolios.scm
+ gnucash/report/reports/standard/test/test-charts.scm
+ gnucash/report/test/test-report.scm
+ gnucash/report/test/test-commodity-utils.scm
+ gnucash/report/test/test-report-extras.scm
+ libgnucash/backend/dbi/test/test-backend-dbi-basic.cpp
+ libgnucash/backend/xml/test/test-xml-pricedb.cpp
+ )
+ for x in "${fixtestfiles[@]}"; do
+ sed -i -e "s|\"/tmp/|\"${T}/|g" "${S}/${x}" || die "sed of ${S}/${x} failed"
+ done
+}
+
+src_configure() {
+ export GUILE_AUTO_COMPILE=0
+
+ local sql_on_off="OFF"
+ if use mysql || use postgres || use sqlite ; then
+ sql_on_off="ON"
+ fi
+
+ local mycmakeargs=(
+ -DCOMPILE_GSCHEMAS=OFF
+ -DDISABLE_NLS=$(usex !nls)
+ -DENABLE_REGISTER2=$(usex register2)
+ -DWITH_AQBANKING=$(usex aqbanking)
+ -DWITH_OFX=$(usex ofx)
+ -DWITH_PYTHON=$(usex python)
+ -DWITH_SQL=${sql_on_off}
+ -DWITH_GNUCASH=$(usex gui)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ LOCALE_TESTS=
+ if type locale >/dev/null 2>&1; then
+ MY_LOCALES="$(locale -a)"
+ if [[ "${MY_LOCALES}" != *en_US* ||
+ "${MY_LOCALES}" != *en_GB* ||
+ "${MY_LOCALES}" != *fr_FR* ]] ; then
+ ewarn "Missing one or more of en_US, en_GB, or fr_FR locales."
+ else
+ LOCALE_TESTS=true
+ fi
+ else
+ ewarn "'locale' not found."
+ fi
+
+ if [[ ! "${LOCALE_TESTS}" ]]; then
+ ewarn "Disabling test-qof and test-gnc-numeric."
+ echo 'set(CTEST_CUSTOM_TESTS_IGNORE test-qof test-gnc-numeric)' \
+ > "${BUILD_DIR}"/CTestCustom.cmake || die "Failed to disable test-qof and test-gnc-numeric!"
+ fi
+
+ cd "${BUILD_DIR}" || die "Failed to enter ${BUILD_DIR}"
+ XDG_DATA_HOME="${T}/$(whoami)" eninja check
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/examples
+ fi
+
+ if use python ; then
+ python_optimize
+ python_optimize "${ED}"/usr/share/gnucash/python
+ fi
+}
+
+pkg_postinst() {
+ if use gui ; then
+ xdg_icon_cache_update
+ gnome2_schemas_update
+ fi
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ if use gui ; then
+ xdg_icon_cache_update
+ gnome2_schemas_update
+ fi
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/app-office/gnucash/metadata.xml b/app-office/gnucash/metadata.xml
new file mode 100644
index 0000000..80150b2
--- /dev/null
+++ b/app-office/gnucash/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <longdescription lang="en">
+ GnuCash is personal and small-business financial-accounting software,
+ freely licensed under the GNU GPL and available for GNU/Linux, BSD,
+ Solaris, Mac OS X and Microsoft Windows.
+ Designed to be easy to use, yet powerful and flexible, GnuCash allows
+ you to track bank accounts, stocks, income and expenses. As quick and
+ intuitive to use as a checkbook register, it is based on professional
+ accounting principles to ensure balanced books and accurate reports.
+ </longdescription>
+ <longdescription lang="it">
+ GnuCash è un programma finanziario e di contabilità adatto all'utilizzo
+ in ambito famigliare o in una piccola impresa, rilasciato gratuitamente
+ con licenza GNU GPL e disponibile per GNU/Linux, BSD, Solaris, Mac OS X
+ e Microsoft Windows.
+ Progettato per essere di semplice utilizzo, ma comunque potente e flessibile,
+ GnuCash permette di tenere traccia dei conti bancari, delle azioni,
+ delle entrate e delle uscite. Intuitivo nell'utilizzo come il registro del
+ libretto degli assegni, si basa sui principi fondamentali della contabilità
+ per garantire l'equilibrio dei saldi e l'accuratezza dei resoconti.
+ </longdescription>
+ <use>
+ <flag name="aqbanking">Connect to some internet banks via AqBanking</flag>
+ <flag name="quotes">Enable Online Stock Quote retrieval</flag>
+ <flag name="register2">Use the new register (Experimental)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gnucash</remote-id>
+ <remote-id type="github">Gnucash/gnucash</remote-id>
+ <changelog>https://github.com/Gnucash/gnucash/releases</changelog>
+ <bugs-to>https://bugs.gnucash.org/</bugs-to>
+ </upstream>
+</pkgmetadata>