summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gnome-code-assistance/gnome-code-assistance-3.14.0.ebuild')
-rw-r--r--dev-util/gnome-code-assistance/gnome-code-assistance-3.14.0.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/dev-util/gnome-code-assistance/gnome-code-assistance-3.14.0.ebuild b/dev-util/gnome-code-assistance/gnome-code-assistance-3.14.0.ebuild
deleted file mode 100644
index 5154647..0000000
--- a/dev-util/gnome-code-assistance/gnome-code-assistance-3.14.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no"
-PYTHON_COMPAT=( python{3_3,3_4} )
-VALA_API_MIN_VERSION="0.20"
-
-inherit gnome2 python-single-r1 vala
-
-DESCRIPTION="Code assistance services for various programming languages"
-HOMEPAGE="https://wiki.gnome.org/Projects/CodeAssistance"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="c css javascript json python vala xml"
-
-REQUIRED_IUSE="
- python? ( ${PYTHON_REQUIRED_USE} )
- c? ( python )
- sh? ( python )
- xml? ( python )
-"
-
-RDEPEND="
- c? (
- sys-devel/llvm
- )
- css? (
- || (
- dev-lang/ruby:2.0
- dev-lang/ruby:1.9
- )
- dev-ruby/sass
- )
- javascript? ( dev-libs/gjs )
- json? (
- ${PYTHON_DEPS}
- dev-python/simplejson[${PYTHON_USEDEP}]
- )
- python? (
- ${PYTHON_DEPS}
- dev-libs/gobject-introspection
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
- )
- vala? (
- $(vala_depend)
- >=dev-libs/glib-2.36:2
- dev-libs/libgee:0.8[introspection]
- )
- xml? ( ${PYTHON_DEPS} )
-"
-# ruby supports needs ruby-rdbus
-# go support with dev-lang/go
-DEPEND="${RDEPEND}
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-# FIXME: automagic for ruby interpreter
-src_configure() {
- python_export_best
- gnome2_src_configure \
- $(use_enable c) \
- $(use_enable css) \
- --disable-go \
- $(use_enable javascript js) \
- $(use_enable json) \
- $(use_enable python) \
- --disable-ruby \
- --enable-sh \
- $(use_enable vala) \
- $(use_enable xml) \
- PYTHON=${PYTHON}
-}