summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/postfix/postfix-2.4.7.ebuild')
-rw-r--r--mail-mta/postfix/postfix-2.4.7.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/mail-mta/postfix/postfix-2.4.7.ebuild b/mail-mta/postfix/postfix-2.4.7.ebuild
index 9aaec00..e6dc55b 100644
--- a/mail-mta/postfix/postfix-2.4.7.ebuild
+++ b/mail-mta/postfix/postfix-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.7.ebuild,v 1.1 2008/03/21 15:03:51 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.7.ebuild,v 1.4 2008/07/22 17:44:21 dertobi123 Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -43,14 +43,17 @@ DEPEND=">=sys-libs/db-3.2
ldap? ( >=net-nds/openldap-1.2 )
mysql? ( virtual/mysql )
pam? ( virtual/pam )
- postgres? ( >=dev-db/postgresql-7.1 )
+ postgres? ( virtual/postgresql-base )
sasl? ( >=dev-libs/cyrus-sasl-2 )
ssl? ( >=dev-libs/openssl-0.9.6g )"
# regular ebuild
RDEPEND="${DEPEND}
>=net-mail/mailbase-0.00
- !mailwrapper? ( !virtual/mta )
+ !mailwrapper? (
+ !virtual/mta
+ !net-mail/mailwrapper
+ )
mailwrapper? ( >=net-mail/mailwrapper-0.2 )
selinux? ( sec-policy/selinux-postfix )"
@@ -188,7 +191,7 @@ src_compile() {
fi
if use postgres ; then
- if best_version '=dev-db/postgresql-7.3*' ; then
+ if best_version '=virtual/postgresql-base-7.3*' ; then
mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql"
else
mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql/pgsql"