summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild')
-rw-r--r--net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild b/net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild
deleted file mode 100644
index c8f5a2c..0000000
--- a/net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tsocks/tsocks-1.8_beta5-r5.ebuild,v 1.8 2010/06/06 14:40:38 armin76 Exp $
-
-EAPI="2"
-
-inherit multilib eutils autotools toolchain-funcs
-
-DESCRIPTION="Transparent SOCKS v4 proxying library"
-HOMEPAGE="http://tsocks.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tsocks/${PN}-${PV/_}.tar.gz
- tordns? ( mirror://gentoo/${PN}-${PV/_beta/b}-tordns1-gentoo-r1.patch.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86-linux"
-IUSE="tordns"
-
-S="${WORKDIR}/${P%%_*}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-gentoo-r3.patch"
- epatch "${FILESDIR}/${P}-bsd.patch"
- use tordns && epatch "../${PN}-${PV/_beta/b}-tordns1-gentoo-r1.patch"
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
-
- # NOTE: the docs say to install it into /lib. If you put it into
- # /usr/lib and add it to /etc/ld.so.preload on many systems /usr isn't
- # mounted in time :-( (Ben Lutgens) <lamer@gentoo.org>
- econf \
- --with-conf=${EROOT}/etc/socks/tsocks.conf \
- --libdir=${EROOT}/$(get_libdir) || die "configure failed"
-}
-
-src_compile() {
- # Fix QA notice lack of SONAME
- emake DYNLIB_FLAGS=-Wl,--soname,libtsocks.so.${PV/_beta*} || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- newbin validateconf tsocks-validateconf
- newbin saveme tsocks-saveme
- dobin inspectsocks
- insinto ${ER}/etc/socks
- doins tsocks.conf.*.example
- dodoc FAQ
- use tordns && dodoc README*
-}
-
-pkg_postinst() {
- einfo "Make sure you create ${ER}/etc/socks/tsocks.conf from one of the examples in that directory"
- einfo "The following executables have been renamed:"
- einfo " ${ER}/usr/bin/saveme renamed to tsocks-saveme"
- einfo " ${ER}/usr/bin/validateconf renamed to tsocks-validateconf"
-}