summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfshuffler/pdfshuffler-0.4.2.ebuild')
-rw-r--r--app-text/pdfshuffler/pdfshuffler-0.4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/pdfshuffler/pdfshuffler-0.4.2.ebuild b/app-text/pdfshuffler/pdfshuffler-0.4.2.ebuild
new file mode 100644
index 0000000..326831e
--- /dev/null
+++ b/app-text/pdfshuffler/pdfshuffler-0.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2-utils fdo-mime distutils
+
+DESCRIPTION="PDF-Shuffler is GUI app that can merge or split pdfs and rotate, crop and rearrange their pages."
+HOMEPAGE="http://sourceforge.net/projects/pdfshuffler/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+DEPEND="dev-python/python-poppler
+ dev-python/pyPdf"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${P}"
+
+DOCS="ChangeLog README TODO AUTHORS"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}