aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2010-10-15 00:45:21 +0200
committerMarkus Meier <maekke@gentoo.org>2010-10-15 00:45:21 +0200
commit719046d4c4324da5639ef93345b9bd94a4df8844 (patch)
tree27473f4005a8492885b50412e7fde600d40592f3 /scripts
parenttweak/style (diff)
downloadmaekke-719046d4c4324da5639ef93345b9bd94a4df8844.tar.gz
maekke-719046d4c4324da5639ef93345b9bd94a4df8844.tar.bz2
maekke-719046d4c4324da5639ef93345b9bd94a4df8844.zip
remove unneeded comments, tweak a bit
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/keyword.sh10
1 files changed, 2 insertions, 8 deletions
diff --git a/scripts/keyword.sh b/scripts/keyword.sh
index a99db72..469ac09 100755
--- a/scripts/keyword.sh
+++ b/scripts/keyword.sh
@@ -69,16 +69,10 @@ for pkg in ${pkgs} ; do
[[ -e ${pn}-${version}.ebuild ]] || die "ebuild not found"
repoman full || die "repoman full failed"
- # detect which arches to commit
+ # detect which arches to commit (the ones w/o stable)
tmparches=""
for arch in ${arches} ; do
- kwv=$(egrep "KEYWORDS=.*(\"| )\<${arch}\>" ${pn}-${version}.ebuild)
- # commented out: not stabilizing stuff for non-stable arches
- #kw=$(egrep "KEYWORDS=.*(\"| )\<${arch}\>" *.ebuild)
- #if [[ -z ${kw} ]] ; then
- # echo "no stable version for ${arch}"
- #elif [[ -z ${kwv} ]] ; then
- if [[ -z ${kwv} ]] ; then
+ if [[ -z $(egrep "KEYWORDS=.*(\"| )\<${arch}\>" ${pn}-${version}.ebuild) ]] ; then
[[ -z ${tmparches} ]] && tmparches="${arch}" || tmparches="${tmparches} ${arch}"
fi
done