aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2013-05-14 20:27:00 +0200
committerMarkus Meier <maekke@gentoo.org>2013-05-14 20:27:00 +0200
commitdc1e5e478c7035d4916d1ac2d4b3c2fcd43f9e7c (patch)
tree96d6e157b9c34bca7982d355304e30efc246568d /scripts
parentpass the --include-arches parameter to repoman to speed up the script (diff)
downloadmaekke-dc1e5e478c7035d4916d1ac2d4b3c2fcd43f9e7c.tar.gz
maekke-dc1e5e478c7035d4916d1ac2d4b3c2fcd43f9e7c.tar.bz2
maekke-dc1e5e478c7035d4916d1ac2d4b3c2fcd43f9e7c.zip
fix --include-arches...
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/keyword.sh8
1 files changed, 3 insertions, 5 deletions
diff --git a/scripts/keyword.sh b/scripts/keyword.sh
index 9e556ae..208101c 100755
--- a/scripts/keyword.sh
+++ b/scripts/keyword.sh
@@ -46,8 +46,6 @@ arches="${2}"
shift 2
pkgs="$@"
-REPOMAN_OPTS="--include-arches "${arches//\~/}""
-
# check if arches are sane
for arch in ${arches} ; do
[[ $(egrep "\<${arch/\~/}\>" ${REPODIR}/profiles/arch.list | wc -l) == 0 ]] && die "invalid arch (${arch})"
@@ -70,7 +68,7 @@ for pkg in ${pkgs} ; do
cvs up -C || die "cvs up failed"
find . -name '.#*' -delete || die "removing .#* failed"
[[ -e ${pn}-${version}.ebuild ]] || die "ebuild (${pn}-${version}) not found"
- repoman full \${REPOMAN_OPTS} || die "repoman full failed on non-modified tree"
+ repoman full --include-arches "${arches//\~/}" || die "repoman full failed on non-modified tree"
# detect which arches to commit (the ones w/o stable)
tmparches=""
@@ -91,10 +89,10 @@ for pkg in ${pkgs} ; do
if [[ -n ${tmparches} ]] ; then
ekeyword ${tmparches} ${pn}-${version}.ebuild || die "ebuild not found"
repoman manifest || die "repoman manifest failed"
- repoman full \${REPOMAN_OPTS} || die "repoman full failed on modified tree"
+ repoman full --include-arches "${arches//\~/}" || die "repoman full failed on modified tree"
echangelog "${msg}" || die "echangelog failed"
repoman manifest || die "repoman manifest failed"
- repoman commit \${REPOMAN_OPTS} -m "${msg}" || die "repoman commit failed"
+ repoman commit --include-arches "${arches//\~/}" -m "${msg}" || die "repoman commit failed"
else
echo "nothing to do here"
fi