aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2011-04-10 22:45:22 +0200
committerMarkus Meier <maekke@gentoo.org>2011-04-10 22:45:22 +0200
commite12610188368601f75d6bff80682384fd5dd87f7 (patch)
tree37b160b708dfefbbd2c719a955a21d748b3a0794 /scripts
parentbe compatible with pybugz 0.9 (diff)
downloadmaekke-e12610188368601f75d6bff80682384fd5dd87f7.tar.gz
maekke-e12610188368601f75d6bff80682384fd5dd87f7.tar.bz2
maekke-e12610188368601f75d6bff80682384fd5dd87f7.zip
add support for unstable arch specific rdeps
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/rdep6
1 files changed, 4 insertions, 2 deletions
diff --git a/scripts/rdep b/scripts/rdep
index 38cbd18..936176a 100755
--- a/scripts/rdep
+++ b/scripts/rdep
@@ -29,7 +29,7 @@ if [[ ! -x $(which q) ]] ; then
exit 1
fi
-if [[ $(egrep "\<${arch}\>" ${REPODIR}/profiles/arch.list | wc -l) == 0 ]]; then
+if [[ $(egrep "\<${arch/\~/}\>" ${REPODIR}/profiles/arch.list | wc -l) == 0 ]]; then
echo "invalid arch ${arch}"
exit 1
fi
@@ -68,7 +68,9 @@ for p in $(grep -v '^[B]' ${tmp} | sort -r); do
# make sure that the file exists, as the local or remote tree
# may be out of date
ebuild="${REPODIR}/${category}/${pn}/${pn}-${version}.ebuild"
- if [[ -e ${ebuild} && $(egrep -H "KEYWORDS=.*( |\")\<${arch}\>" \
+ [[ "${arch}" != "${arch/\~/}" ]] && expr="KEYWORDS=.*\<${arch/\~/}\>" \
+ || expr="KEYWORDS=.*( |\")\<${arch}\>"
+ if [[ -e ${ebuild} && $(egrep -H "${expr}" \
${ebuild} | wc -l) == 1 ]]; then
if [[ ${last_pn} != ${category}/${pn} ]]; then
[[ -z ${use} ]] && echo "=${cpv}" || echo "=${cpv}[${use}]"