summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-11-24 23:16:46 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-11-24 23:16:46 +0000
commit53cc338d28e2bb144dc550fa24257dc4fdb64bd8 (patch)
tree055ae447fce895bc18c1a78b3c1c7aea59f2a0fe
parentInitial commit (diff)
downloadmasterdriverz-53cc338d28e2bb144dc550fa24257dc4fdb64bd8.tar.gz
masterdriverz-53cc338d28e2bb144dc550fa24257dc4fdb64bd8.tar.bz2
masterdriverz-53cc338d28e2bb144dc550fa24257dc4fdb64bd8.zip
Initial commit
svn path=/; revision=6
-rw-r--r--sys-kernel/beyond-sources/ChangeLog8
-rw-r--r--sys-kernel/beyond-sources/Manifest9
-rw-r--r--sys-kernel/beyond-sources/beyond-sources-2.6.17_p30.ebuild69
-rw-r--r--sys-kernel/beyond-sources/files/digest-beyond-sources-2.6.17_p306
4 files changed, 92 insertions, 0 deletions
diff --git a/sys-kernel/beyond-sources/ChangeLog b/sys-kernel/beyond-sources/ChangeLog
new file mode 100644
index 0000000..fcd7f92
--- /dev/null
+++ b/sys-kernel/beyond-sources/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-kernel/beyond-sources
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Nov 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+ +beyond-sources-2.6.17_p30.ebuild:
+ Initial commit
+
diff --git a/sys-kernel/beyond-sources/Manifest b/sys-kernel/beyond-sources/Manifest
new file mode 100644
index 0000000..d6c5d58
--- /dev/null
+++ b/sys-kernel/beyond-sources/Manifest
@@ -0,0 +1,9 @@
+DIST linux-2.6.17.tar.bz2 6605390 RMD160 13a0b1f4866bb83cbbff7cc5663ea4f39d949484 SHA1 b15905a2bce6b0162e832ba774c4f8e6f976a72b SHA256 80b1b61895bb896ba340c50a74082524115d7cc8c2191df7efd607b92c14608e
+DIST patch-2.6.17-beyond3.bz2 1007371 RMD160 a4933051cf8a247c83fccd2a2b58b27699e58e19 SHA1 650ad1f1e09de7d1147d930780ffae07ba1d570b SHA256 a65b37870d49f0458660666c1b406565a6d412d9c2da7af1c2744d710bf9202e
+EBUILD beyond-sources-2.6.17_p30.ebuild 1998 RMD160 90972d13ef91410f66f37fd777dcad083387ca96 SHA1 1693f88e3072904ac07976e83598c7c810d9c128 SHA256 63abbd8c7d883fb3e1264faf7b2d4a3af0aa6da55c489dabf186d262cb85d713
+MD5 d559c344582481e661f8f7306c757b7a beyond-sources-2.6.17_p30.ebuild 1998
+RMD160 90972d13ef91410f66f37fd777dcad083387ca96 beyond-sources-2.6.17_p30.ebuild 1998
+SHA256 63abbd8c7d883fb3e1264faf7b2d4a3af0aa6da55c489dabf186d262cb85d713 beyond-sources-2.6.17_p30.ebuild 1998
+MD5 73a2de077e21b8a4f14c85f41e983c64 files/digest-beyond-sources-2.6.17_p30 500
+RMD160 35665e60e59a201af48a0bf5d5ebf820dbe4444c files/digest-beyond-sources-2.6.17_p30 500
+SHA256 39b8885485abb8733a01a0c0883665044c974938c09af525084fc207a2121bfe files/digest-beyond-sources-2.6.17_p30 500
diff --git a/sys-kernel/beyond-sources/beyond-sources-2.6.17_p30.ebuild b/sys-kernel/beyond-sources/beyond-sources-2.6.17_p30.ebuild
new file mode 100644
index 0000000..e78f5dd
--- /dev/null
+++ b/sys-kernel/beyond-sources/beyond-sources-2.6.17_p30.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Beyond Kernel Sources -- successor to arch, tiger, nitro"
+HOMEPAGE="http://iphitus.loudas.com/beyond.html"
+KEYWORDS="~x86"
+DEPEND=""
+RDEPEND=""
+
+K_NOUSENAME="yes"
+K_EXTRAEINFO="\
+The beyond stable tree is a patchset based on the CK patchset. It aims to
+include a variety of popular features and updates that have not yet made
+it to the vanilla kernel, while remaining relatively stable. Con Kolivas'
+CK patchset is the most important part of beyond stable tree, as it
+provides the great interactivity and responsiveness improvements that it
+is noted for.
+
+Features
+-ck(s) Con Kolivas Patchset, (server version available as option) -ide
+libATA/ide updates, Alsa updates and fixes, Dothan Speedstep, Pentium M
+undervolt, IBM ACPI fan control, Suspend2, vesafb-tng, reiser4, unionfs
+squashfs, realtime-lsm, fbsplash, configurable mouse polling support,
+custom dsdt, Layer7, various fixes and updates."
+
+ETYPE="sources"
+inherit kernel-2
+#detect_version
+
+MY_N=${PN/-sources/}
+# A few hacks to set beyond version via _p instead of -r
+# _p#[#] is mandatory
+MY_P=${PV/*_p/}
+MY_P=${MY_P/-r*/}
+# now see if version is dotted (2 chars)
+# strip off rightmost 0
+if [ ${MY_P: -1} = "0" ] ; then
+ MY_P=${MY_P:0:1}
+fi
+# if length is not 1, then add a dot
+if [ ${#MY_P} -ne "1" ] ; then
+ MY_P=${MY_P:0:1}.${MY_P:1}
+fi
+# accomodate revisions in patchset
+if [ ${PR} != "r0" ] ; then
+ MY_PR=${PR/r/-r}
+else
+ MY_PR=""
+fi
+EXTRAVERSION=-${MY_N}${MY_P}${MY_PR}
+KV_FULL=${OKV}${EXTRAVERSION}
+KV_CK=${KV_FULL/-r*/}
+
+detect_version
+
+CK_PATCH="patch-${KV_CK}.bz2"
+UNIPATCH_LIST="${DISTDIR}/${CK_PATCH}"
+
+SRC_URI="${KERNEL_URI}
+ http://iphitus.loudas.com/beyond/${OKV}/${KV_CK}/${CK_PATCH}"
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo "The beyond sources are based on the -ck patchset."
+ einfo "The ck-server patches are integrated, and are selectable"
+ einfo "during the config process."
+}
diff --git a/sys-kernel/beyond-sources/files/digest-beyond-sources-2.6.17_p30 b/sys-kernel/beyond-sources/files/digest-beyond-sources-2.6.17_p30
new file mode 100644
index 0000000..60ae80c
--- /dev/null
+++ b/sys-kernel/beyond-sources/files/digest-beyond-sources-2.6.17_p30
@@ -0,0 +1,6 @@
+MD5 8fc05c776ecaea48797bed93c00b7503 linux-2.6.17.tar.bz2 6605390
+RMD160 13a0b1f4866bb83cbbff7cc5663ea4f39d949484 linux-2.6.17.tar.bz2 6605390
+SHA256 80b1b61895bb896ba340c50a74082524115d7cc8c2191df7efd607b92c14608e linux-2.6.17.tar.bz2 6605390
+MD5 46f1eb95e00cfe733e5400cd89f3a259 patch-2.6.17-beyond3.bz2 1007371
+RMD160 a4933051cf8a247c83fccd2a2b58b27699e58e19 patch-2.6.17-beyond3.bz2 1007371
+SHA256 a65b37870d49f0458660666c1b406565a6d412d9c2da7af1c2744d710bf9202e patch-2.6.17-beyond3.bz2 1007371