summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2009-05-22 09:10:03 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2009-05-22 09:10:03 +0900
commit3703e53f969ff45d98e342e068d39da0c70a0fbe (patch)
tree14128b4f2b872a7ae22a5b8cc91999e26743fdc3 /x11-wm
parentx11-wm/awesome: fixed dependency. (diff)
downloadmatsuu-3703e53f969ff45d98e342e068d39da0c70a0fbe.tar.gz
matsuu-3703e53f969ff45d98e342e068d39da0c70a0fbe.tar.bz2
matsuu-3703e53f969ff45d98e342e068d39da0c70a0fbe.zip
x11-wm/musca: initial import.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/musca/Manifest2
-rw-r--r--x11-wm/musca/musca-0.9.22.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/musca/Manifest b/x11-wm/musca/Manifest
new file mode 100644
index 0000000..9661602
--- /dev/null
+++ b/x11-wm/musca/Manifest
@@ -0,0 +1,2 @@
+DIST musca-0.9.22.tgz 52198 RMD160 2a719822f45d3b589659cf38bb073a8bbee130da SHA1 4a143b710e66d57cc57656b8a31eb607ae2327ab SHA256 03e16d9e33e7ea4db506e1428a3f63a49c9e5589508412dd547e15ec5e467082
+EBUILD musca-0.9.22.ebuild 733 RMD160 2ad5d180006727e528e8d9999d26cbf10fcd62d9 SHA1 44c82b5793802f5e567fc59703dd53b3aa609b15 SHA256 5c02592f5eacaa5d31b6d6035dfd6a36077c07df3e1c5c5e2933679c43e42feb
diff --git a/x11-wm/musca/musca-0.9.22.ebuild b/x11-wm/musca/musca-0.9.22.ebuild
new file mode 100644
index 0000000..de80aba
--- /dev/null
+++ b/x11-wm/musca/musca-0.9.22.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="A simple tiling window manager for X, with features nicked from ratpoison and dwm"
+HOMEPAGE="http://aerosuidae.net/musca.html"
+SRC_URI="http://aerosuidae.net/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ x11-misc/dmenu"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+
+ sed -i \
+ -e "s:X11R6/include:include:" \
+ -e "s:X11R6/lib:$(get_libdir):" \
+ Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin musca || die
+
+ doman musca.1
+}