summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild')
-rw-r--r--dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild b/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild
new file mode 100644
index 0000000..5f5f146
--- /dev/null
+++ b/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.1.3.ebuild,v 1.1 2007/07/11 23:40:23 rbu Exp $
+
+inherit python eutils distutils
+
+DESCRIPTION="Basic Framework for all Kaa Python Modules."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sqlite lirc"
+
+RDEPEND="dev-libs/libxml2
+ dev-python/pynotifier
+ sqlite? ( >=dev-libs/glib-2.4.0 >=dev-python/pysqlite-2.2 )
+ lirc? ( dev-python/pylirc )"
+
+DOCS="AUTHORS"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ rm -rf src/notifier/pynotifier
+}
+
+pkg_setup() {
+ if !(built_with_use dev-libs/libxml2 python); then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+}