summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/networkmanager/networkmanager-9999.ebuild')
-rw-r--r--net-misc/networkmanager/networkmanager-9999.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/net-misc/networkmanager/networkmanager-9999.ebuild b/net-misc/networkmanager/networkmanager-9999.ebuild
new file mode 100644
index 0000000..133e32f
--- /dev/null
+++ b/net-misc/networkmanager/networkmanager-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Ebuild from http://forums.gentoo.org/viewtopic-t-629987.html
+
+
+inherit gnome2 subversion autotools eutils
+
+# NetworkManager likes itself with capital letters
+MY_P=${P/networkmanager/NetworkManager}
+
+DESCRIPTION="Network configuration and management in an easy way. Desktop environment independent."
+HOMEPAGE="http://www.gnome.org/projects/NetworkManager/"
+ESVN_REPO_URI="svn://svn.gnome.org/svn/NetworkManager/trunk"
+
+SRC_URI=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dhclient dhcpcd gnutls nss doc"
+
+# Yes, I know that configure will accept libnl 1.0-pre8, however we only have
+# 1.1 in the tree, therefore dep on it.
+RDEPEND=">=sys-apps/dbus-1.2
+ >=dev-libs/dbus-glib-0.75
+ >=sys-apps/hal-0.5.9
+ >=dev-libs/libnl-1.1
+ >=net-wireless/wireless-tools-28_pre9
+ >=net-wireless/wpa_supplicant-0.5
+ >=dev-libs/glib-2.16
+ >=sys-auth/policykit-0.8
+
+ dhclient? (
+ dhcpcd? ( >=net-misc/dhcpcd-4.0.0_rc3 )
+ !dhcpcd? ( >=net-misc/dhcp-3.0.0 ) )
+ !dhclient? ( >=net-misc/dhcpcd-4.0.0_rc3 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+PDEPEND="gnome? ( >=gnome-extra/nm-applet-9999 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+#USE_DESTDIR="1"
+
+G2CONF="${G2CONF} \
+ --disable-more-warnings \
+ --localstatedir=/var \
+ --with-distro=gentoo"
+
+ # if both flags are used we default to dhcpcd
+ # if none flag is used we force dhcpcd
+ if use dhclient ; then
+ if use dhcpcd ; then
+ G2CONF="${G2CONF} --with-dhcp-client=dhcpcd"
+ else
+ G2CONF="${G2CONF} --with-dhcp-client=dhclient"
+ fi
+ else
+ G2CONF="${G2CONF} --with-dhcp-client=dhcpcd"
+ fi
+
+
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix up the dbus conf file to use plugdev group
+ epatch "${FILESDIR}"/${P}-confchanges.patch
+ gtkdocize
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "You need to be in the plugdev group in order to use NetworkManager"
+ elog "Problems with your hostname getting changed?"
+ elog ""
+ elog "Add the following to /etc/dhcp/dhclient.conf"
+ elog 'send host-name "YOURHOSTNAME";'
+ elog 'supersede host-name "YOURHOSTNAME";'
+
+ elog "You will need to restart DBUS if this is your first time"
+ elog "installing NetworkManager."
+}