summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTomáš Chvátal <scarabeus@gentoo.org>2010-05-17 14:47:35 +0200
committerTomáš Chvátal <scarabeus@gentoo.org>2010-05-17 14:47:35 +0200
commita311d46fc723ba9d36feee4d3f4c9d383dea9875 (patch)
treeee86021620e49e0f4a88017fd5633e17a057aae7 /sys-fs
parentCorosync version bump. (diff)
downloadscarabeus-a311d46fc723ba9d36feee4d3f4c9d383dea9875.tar.gz
scarabeus-a311d46fc723ba9d36feee4d3f4c9d383dea9875.tar.bz2
scarabeus-a311d46fc723ba9d36feee4d3f4c9d383dea9875.zip
[sys-fs/ocfs2-tools] New package.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ocfs2-tools/Manifest3
-rw-r--r--sys-fs/ocfs2-tools/files/1.4.4-gcc45.patch21
-rw-r--r--sys-fs/ocfs2-tools/ocfs2-tools-1.4.4.ebuild55
3 files changed, 79 insertions, 0 deletions
diff --git a/sys-fs/ocfs2-tools/Manifest b/sys-fs/ocfs2-tools/Manifest
new file mode 100644
index 0000000..ea0fb2b
--- /dev/null
+++ b/sys-fs/ocfs2-tools/Manifest
@@ -0,0 +1,3 @@
+AUX 1.4.4-gcc45.patch 807 RMD160 6e90024195735b7daa93a71f07ee80cd3e1677ed SHA1 fdbb4b1a9aeefd1151f926913d301fd178a6cb7f SHA256 416893dcab5d3aa92a1c9dc1b4c83201ef914c159533c1f1f0a37f35cf2c347d
+DIST ocfs2-tools-1.4.4.tar.gz 713145 RMD160 353733c6a7e17b1aba17d9d22546311eec4a02f6 SHA1 fd36df819a0677c5de8d7d59c804fb6cfa862d82 SHA256 fcfcce1057830c1975d57effc25cc78f3099be0c9e35ea92a9b9dbb185946530
+EBUILD ocfs2-tools-1.4.4.ebuild 1127 RMD160 586a3df8249f1fb4ba746cf15ff67e04c84b4be0 SHA1 7f1edb3298c7f586f45dbb764fefcaf602512b7e SHA256 7d2563bae19d05f520b5c7b4897c9159b2a0c9c3006c4f2467d6b618569b9ad5
diff --git a/sys-fs/ocfs2-tools/files/1.4.4-gcc45.patch b/sys-fs/ocfs2-tools/files/1.4.4-gcc45.patch
new file mode 100644
index 0000000..0db24f4
--- /dev/null
+++ b/sys-fs/ocfs2-tools/files/1.4.4-gcc45.patch
@@ -0,0 +1,21 @@
+diff -urN ocfs2-tools-1.4.3.orig//mount.ocfs2/mount.ocfs2.c ocfs2-tools-1.4.3/mount.ocfs2/mount.ocfs2.c
+--- ocfs2-tools-1.4.3.orig//mount.ocfs2/mount.ocfs2.c 2009-04-14 00:10:40.000000000 +0200
++++ ocfs2-tools-1.4.3/mount.ocfs2/mount.ocfs2.c 2010-03-24 07:23:45.000000000 +0100
+@@ -261,7 +261,7 @@
+ char *extra = NULL;
+ int dev_ro = 0;
+ char *hbstr = NULL;
+- char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1] = "";
++ char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1];
+ ocfs2_filesys *fs = NULL;
+ struct o2cb_cluster_desc cluster;
+ struct o2cb_region_desc desc;
+@@ -269,6 +269,8 @@
+ int hb_started = 0;
+ struct stat statbuf;
+
++ stackstr[0] = '\0';
++
+ initialize_ocfs_error_table();
+ initialize_o2dl_error_table();
+ initialize_o2cb_error_table();
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.4.4.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.4.4.ebuild
new file mode 100644
index 0000000..e60ad6e
--- /dev/null
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.4.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="gtk? 2"
+inherit python base versionator
+
+DESCRIPTION="Support programs for the Oracle Cluster Filesystem 2"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs2-tools/"
+SRC_URI="http://oss.oracle.com/projects/${PN}/dist/files/source/v$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk"
+
+RDEPEND="
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-process/psmisc
+ gtk? (
+ dev-python/pygtk
+ )
+"
+# 99% of deps this thing has is automagic
+# specialy cluster things corosync/pacemaker
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-gcc45.patch"
+)
+
+DOCS=(
+ "${S}/documentation/samples/cluster.conf"
+ "${S}/documentation/users_guide.txt"
+)
+
+MAKEOPTS+=" -j1"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_enable debug debugexe) \
+ $(use_enable gtk ocfs2console) \
+ --enable-dynamic-fsck \
+ --enable-dynamic-ctl
+}