summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 97887b7..d270bbe 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -92,12 +92,14 @@ pkg_preinst() {
# so handle upgraders
if ! has_version sys-apps/openrc; then
local x= xtra=
- use kernel_linux && xtra="${xtra} procfs sysctl"
+ use kernel_linux && xtra="${xtra} mtab procfs sysctl"
use kernel_FreeBSD && xtra="${xtra} savecore dumpon"
- for x in swap ${xtra}; do
+ for x in fsck root swap ${xtra}; do
[ -e "${ROOT}"etc/runlevels/boot/"${x}" ] && continue
ln -snf /etc/init.d/"${x}" "${ROOT}"etc/runlevels/boot/"${x}"
done
+
+ # We should also remove checkfs and checkroot
fi
# Upgrade out state for baselayout-1 users
@@ -121,8 +123,8 @@ pkg_preinst() {
}
pkg_postinst() {
- # Make our runlevels if they don't exist
- if [ ! -e "${ROOT}"etc/runlevels ]; then
+ # Make our runlevels if they don't exist or we're a development version.
+ if [ ! -e "${ROOT}"etc/runlevels -o "${PV}" = "9999" ]; then
einfo "Copying across default runlevels"
cp -RPp "${ROOT}"usr/share/"${PN}"/runlevels "${ROOT}"/etc
fi