summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-11-01 16:19:10 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-11-01 16:19:10 +0000
commitd8636c4ef02135b40acbd9ad3ca21042044c7913 (patch)
treee4c26f3ae63a4eb8026a726de10c167782e2e78e
parentAdding a new openal patch to set the default frequency to 48000 from 44100. (diff)
downloadwolf31o2-d8636c4ef02135b40acbd9ad3ca21042044c7913.tar.gz
wolf31o2-d8636c4ef02135b40acbd9ad3ca21042044c7913.tar.bz2
wolf31o2-d8636c4ef02135b40acbd9ad3ca21042044c7913.zip
Adding an initial Enemy Territory: Quake Wars ebuild. This needs a little work, as it needs to be broken into binary and data.
svn path=/; revision=79
-rw-r--r--games-fps/etqw-bin/Manifest2
-rw-r--r--games-fps/etqw-bin/etqw-bin-1.2.2.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/games-fps/etqw-bin/Manifest b/games-fps/etqw-bin/Manifest
new file mode 100644
index 0000000..f85dbaa
--- /dev/null
+++ b/games-fps/etqw-bin/Manifest
@@ -0,0 +1,2 @@
+DIST ETQW-client-1.2-full.r2.x86.run 285781273 RMD160 6a26f55b5e9f3d3eef5e5e53785faae70cb9debc SHA1 bea26618a4ade4f85f9a7d9867c30b86c0353669 SHA256 5c92e20d999e136b758e66f819b82fb4be1243c78cede590e842dae533c31730
+EBUILD etqw-bin-1.2.2.ebuild 2704 RMD160 c0d2aff08f41a69c6500ac1b769b1217d1f8013c SHA1 c444ad7dce6a6842124964fd56e35c5d569963e7 SHA256 a46283842d7cbfa1b511bf8bacc37170a5a14ae082c2402210fbaa53803563be
diff --git a/games-fps/etqw-bin/etqw-bin-1.2.2.ebuild b/games-fps/etqw-bin/etqw-bin-1.2.2.ebuild
new file mode 100644
index 0000000..f904195
--- /dev/null
+++ b/games-fps/etqw-bin/etqw-bin-1.2.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild,v 1.2 2007/08/20 17:23:52 wolf31o2 Exp $
+
+inherit eutils versionator games
+
+VER="$(get_version_component_range 1-2)"
+REV="$(get_version_component_range 3-3)"
+MY_PV="${VER}-full.r${REV}"
+MY_BODY="ETQW-client-${MY_PV}.x86"
+
+DESCRIPTION="Enemy Territory"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+#SRC_URI="${MY_BODY}.run"
+SRC_URI="ftp://ftp.idsoftware.com/idstuff/etqw/${MY_BODY}.run"
+
+#LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa cdinstall dedicated opengl"
+
+RESTRICT="strip"
+
+UIDEPEND="virtual/opengl
+ x86? (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ media-libs/libsdl )
+ amd64? (
+ app-emulation/emul-linux-x86-compat
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-xlibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ >=x11-drivers/ati-drivers-8.8.25-r1 ) )
+ alsa? ( >=media-libs/alsa-lib-1.0.6 )"
+
+RDEPEND="sys-libs/glibc
+ dedicated? ( app-misc/screen )
+ amd64? ( app-emulation/emul-linux-x86-baselibs )
+ opengl? ( ${UIDEPEND} )
+ !dedicated? ( !opengl? ( ${UIDEPEND} ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/etqw-client
+Ddir=${D}/${dir}
+
+#GAMES_CHECK_LICENSE="yes"
+
+QA_TEXTRELS="${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbags.so
+ ${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbsv.so"
+QA_EXECSTACK="${dir:1}/etqw.x86
+ ${dir:1}/etqwded.x86
+ ${dir:1}/libgcc_s.so.1
+ ${dir:1}/libjpeg.so.62
+ ${dir:1}/libstdc++.so.6
+ ${dir:1}/libCgx86.so"
+
+src_unpack() {
+ unpack ${A}
+ mv data/* .
+
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r pb base || die "doins pb base"
+
+ exeinto "${dir}"
+ doexe openurl.sh || die "openurl.sh"
+ doexe {etqw.x86,etqwded.x86,libCgx86.so,*.so.?} \
+ || die "doexe x86 exes/libs"
+
+ insinto "${dir}"/base
+ doins base/* || die "doins base"
+ if use dedicated ; then
+ games_make_wrapper etqwded ./etqwded.x86 "${dir}" "${dir}"
+ fi
+
+ if use opengl || ! use dedicated ; then
+ doicon etqw_icon.png || die "doicon"
+ games_make_wrapper etqw "./etqw.x86" "${dir}" "${dir}"
+ make_desktop_entry etqw "Enemy Territory: Quake Wars" etqw.png
+ fi
+ # if use cdinstall ; then
+ # doins -r Setup/Data/base/pak00* zpak* megatextures
+ # fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "You need to copy pak00*.pk4, zpak_english000.pk4 and the"
+ elog "megatextures directory from either your installation media or your hard drive to"
+ elog "${dir}/base before running the game."
+ echo
+
+
+ if use opengl || !use dedicated ; then
+ elog "To play the game, run: etqw"
+ echo
+ fi
+}
+