summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagcon/nagcon-0.0.30.ebuild')
-rw-r--r--net-analyzer/nagcon/nagcon-0.0.30.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/nagcon/nagcon-0.0.30.ebuild b/net-analyzer/nagcon/nagcon-0.0.30.ebuild
new file mode 100644
index 0000000..13f663d
--- /dev/null
+++ b/net-analyzer/nagcon/nagcon-0.0.30.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic
+
+IUSE=""
+DESCRIPTION="Nagios Console"
+HOMEPAGE="http://www.vanheusden.com/nagcon/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+DEPEND="sys-libs/ncurses virtual/libstdc++"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ # TODO: fix CXXFLAGS in Makefile
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin nagcon
+ dodoc readme.txt
+}