summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/opencl')
-rw-r--r--virtual/opencl/ChangeLog14
-rw-r--r--virtual/opencl/Manifest3
-rw-r--r--virtual/opencl/metadata.xml5
-rw-r--r--virtual/opencl/opencl-0.ebuild24
4 files changed, 46 insertions, 0 deletions
diff --git a/virtual/opencl/ChangeLog b/virtual/opencl/ChangeLog
new file mode 100644
index 0000000..7de2a68
--- /dev/null
+++ b/virtual/opencl/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for virtual/opencl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.2 2011/12/20 22:09:15 vapier Exp $
+
+ 20 Dec 2011; Mike Frysinger <vapier@gentoo.org> opencl-0.ebuild:
+ Drop ATI from dep list for now since that only provides the libraries and not
+ the required headers #392179#2 by Emil Karlson.
+
+*opencl-0 (20 Dec 2011)
+
+ 20 Dec 2011; Mike Frysinger <vapier@gentoo.org> +opencl-0.ebuild,
+ +metadata.xml:
+ Initial ebuild by me for #392179 by Michal Pytasz.
+
diff --git a/virtual/opencl/Manifest b/virtual/opencl/Manifest
new file mode 100644
index 0000000..75db4c0
--- /dev/null
+++ b/virtual/opencl/Manifest
@@ -0,0 +1,3 @@
+EBUILD opencl-0.ebuild 696 RMD160 f06efa0c5a4e7b1e5ee32b355a18a0293edb3f09 SHA1 2bd4609c043b9fd8b895aa8949191cf2148cf939 SHA256 3398e00ebba8543c93209d834b95248c84bcc5f5a2288186e0f4127629b3523a
+MISC ChangeLog 563 RMD160 aa2dd37824bca3c9e8676a43f7e4856190b82ab0 SHA1 fa77721c3e624a171d1b40ca84f6edf440e00c90 SHA256 d73326fe95e263947a3266673baa0894b270efa8e32a6b63ba44d0f53a07a9a7
+MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
diff --git a/virtual/opencl/metadata.xml b/virtual/opencl/metadata.xml
new file mode 100644
index 0000000..01c4c00
--- /dev/null
+++ b/virtual/opencl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/virtual/opencl/opencl-0.ebuild b/virtual/opencl/opencl-0.ebuild
new file mode 100644
index 0000000..6eca249
--- /dev/null
+++ b/virtual/opencl/opencl-0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/opencl-0.ebuild,v 1.2 2011/12/20 22:09:15 vapier Exp $
+
+# Until ATI's SDK is in the tree, nvidia is the only
+# viable provider #392179 #257626
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+#CARDS=( fglrx nvidia )
+CARDS=( nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+REQUIRED_USE="|| ( ${IUSE} )"
+
+# video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
+RDEPEND="|| (
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers
+ || ( dev-util/opencl-headers >=dev-util/nvidia-cuda-toolkit-3.1 ) )
+ )"