aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Schwinge <tschwinge@gnu.org>2013-05-16 21:54:34 +0000
committerThomas Schwinge <tschwinge@gnu.org>2013-05-16 21:54:34 +0000
commit036c3acbab525e5125bf2d1f98cb041ed95e21d5 (patch)
tree0d2bc90b74fc27257dff40a62b8d327bb07a8727 /gdb/configure
parent * doc/c-msp430.texi: Fix typo. (diff)
downloadbinutils-gdb-036c3acbab525e5125bf2d1f98cb041ed95e21d5.tar.gz
binutils-gdb-036c3acbab525e5125bf2d1f98cb041ed95e21d5.tar.bz2
binutils-gdb-036c3acbab525e5125bf2d1f98cb041ed95e21d5.zip
gdb/
2013-05-16 Yue Lu <hacklu.newborn@gmail.com> * configure.ac: Ensure MIG is available when building for GNU Hurd hosts. * configure: Regenerate.
Diffstat (limited to 'gdb/configure')
-rwxr-xr-xgdb/configure11
1 files changed, 9 insertions, 2 deletions
diff --git a/gdb/configure b/gdb/configure
index 60337914231..f0cdeb20a56 100755
--- a/gdb/configure
+++ b/gdb/configure
@@ -6136,8 +6136,10 @@ else
fi
-# Needed for GNU/Hurd.
-if test -n "$ac_tool_prefix"; then
+case $host_os in
+ gnu*)
+ # Needed for GNU Hurd hosts.
+ if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}mig", so it can be a program name with args.
set dummy ${ac_tool_prefix}mig; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
@@ -6229,6 +6231,11 @@ else
MIG="$ac_cv_prog_MIG"
fi
+ if test x"$MIG" = x; then
+ as_fn_error "MIG not found but required for $host hosts" "$LINENO" 5
+ fi
+ ;;
+esac
# ---------------------- #
# Checks for libraries. #