aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2017-09-26 16:23:19 +0100
committerPedro Alves <palves@redhat.com>2017-09-26 16:23:19 +0100
commit5007d765ae09c10c7f3b18bb16841b9d2d59e181 (patch)
treeb43b21ec5b4d3e5f8dc812c171c78c78bb61e83b /gdb/gdb_curses.h
parentFix an assertion failure when parsing a fuzzed x86_64 ELF binary. (diff)
downloadbinutils-gdb-5007d765ae09c10c7f3b18bb16841b9d2d59e181.tar.gz
binutils-gdb-5007d765ae09c10c7f3b18bb16841b9d2d59e181.tar.bz2
binutils-gdb-5007d765ae09c10c7f3b18bb16841b9d2d59e181.zip
Allow linking GDB with ncursesw
Triggered by https://launchpad.net/bugs/1275210, to be able to cope with UTF-8 characters in gdbtui. Reference: https://sourceware.org/ml/gdb-patches/2017-09/msg00356.html gdb/ChangeLog: 2017-09-26 Matthias Klose <doko@ubuntu.com> * configure.ac: Search ncursesw before ncurses. Check ncursesw/ncurses.h before ncurses/ncurses.h. * gdb_curses.h: Include <ncursesw/ncurses.h> * config.in, configure: Regenerate.
Diffstat (limited to 'gdb/gdb_curses.h')
-rw-r--r--gdb/gdb_curses.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/gdb/gdb_curses.h b/gdb/gdb_curses.h
index 72fafe309ba..4f9ed114171 100644
--- a/gdb/gdb_curses.h
+++ b/gdb/gdb_curses.h
@@ -39,7 +39,9 @@
#define NOMACROS
#define NCURSES_NOMACROS
-#if defined (HAVE_NCURSES_NCURSES_H)
+#if defined (HAVE_NCURSESW_NCURSES_H)
+#include <ncursesw/ncurses.h>
+#elif defined (HAVE_NCURSES_NCURSES_H)
#include <ncurses/ncurses.h>
#elif defined (HAVE_NCURSES_H)
#include <ncurses.h>