aboutsummaryrefslogtreecommitdiff
path: root/gdb/top.c
diff options
context:
space:
mode:
authorSergei Trofimovich <siarheit@google.com>2019-03-17 22:48:02 +0000
committerTom Tromey <tromey@adacore.com>2019-04-19 14:05:47 -0600
commit189b8c2e104017600104457b97315da74a22f549 (patch)
tree49d678df172cb291de0261e10a8c389a63ebd001 /gdb/top.c
parentPrint non-Ada unions without crashing (diff)
downloadbinutils-gdb-189b8c2e104017600104457b97315da74a22f549.tar.gz
binutils-gdb-189b8c2e104017600104457b97315da74a22f549.tar.bz2
binutils-gdb-189b8c2e104017600104457b97315da74a22f549.zip
gdb/configure.ac: add --enable-source-highlight
Allow disabling source-highlight dependency autodetection even it exists in the system. More details on problem of automatic dependencies: https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Automagic_dependencies Noticed by Jeroen Roovers in https://bugs.gentoo.org/680238 * configure.ac: add --enable-source-highlight switch. * configure: Regenerate. * top.c (print_gdb_version): plumb --enable-source-highlight status to "show configuration". gdb/ChangeLog 2019-04-19 Sergei Trofimovich <siarheit@google.com> * configure.ac: add --enable-source-highlight switch. * configure: Regenerate. * top.c (print_gdb_version): plumb --enable-source-highlight status to "show configuration".
Diffstat (limited to 'gdb/top.c')
-rw-r--r--gdb/top.c9
1 files changed, 9 insertions, 0 deletions
diff --git a/gdb/top.c b/gdb/top.c
index 60ca74da253..9a1c258d3f7 100644
--- a/gdb/top.c
+++ b/gdb/top.c
@@ -1450,6 +1450,15 @@ This GDB was configured as follows:\n\
--without-guile\n\
"));
#endif
+#if HAVE_SOURCE_HIGHLIGHT
+ fprintf_filtered (stream, _("\
+ --enable-source-highlight\n\
+"));
+#else
+ fprintf_filtered (stream, _("\
+ --disable-source-highlight\n\
+"));
+#endif
#ifdef RELOC_SRCDIR
fprintf_filtered (stream, _("\
--with-relocated-sources=%s\n\