aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2020-06-09 15:32:43 +0200
committerGitHub <noreply@github.com>2020-06-09 15:32:43 +0200
commit51ae31e5b93b986e57a7e18e25f981a6ffcdefb7 (patch)
treea28555c9ee1fbffb12be5d28fdbaa5dcf283f0a9 /configure.ac
parentRemove reference to 3.7 and 3.8 backports. (GH-20754) (diff)
downloadcpython-51ae31e5b93b986e57a7e18e25f981a6ffcdefb7.tar.gz
cpython-51ae31e5b93b986e57a7e18e25f981a6ffcdefb7.tar.bz2
cpython-51ae31e5b93b986e57a7e18e25f981a6ffcdefb7.zip
bpo-40684: Fix make install for platlibdir=lib64 (GH-20736)
"make install" now uses the PLATLIBDIR variable for the destination lib-dynload/ directory when ./configure --with-platlibdir is used. Update --with-platlibdir comment in configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 84d1f00983f..30856c8b688 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4770,7 +4770,11 @@ else
fi
-# Check for --with-libdir-name
+AC_SUBST(BINLIBDEST)
+BINLIBDEST='$(LIBDIR)/python$(VERSION)'
+
+
+# Check for --with-platlibdir
# /usr/$LIDIRNAME/python$VERSION
AC_SUBST(PLATLIBDIR)
PLATLIBDIR="lib"
@@ -4787,6 +4791,7 @@ if test -n "$withval" -a "$withval" != yes -a "$withval" != no
then
AC_MSG_RESULT(yes)
PLATLIBDIR="$withval"
+ BINLIBDEST='${exec_prefix}/${PLATLIBDIR}/python$(VERSION)'
else
AC_MSG_RESULT(no)
fi],