aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2020-05-17 08:32:46 +0200
committerGitHub <noreply@github.com>2020-05-17 02:32:46 -0400
commit9a45bfe6f4aedd2a9d94cb12aa276057b15d8b63 (patch)
treede9431975c00c9fc34a3b7ba72bfc3bf20c86217 /setup.py
parentbpo-29587: Add another test for the gen.throw() fix. (GH-19859) (diff)
downloadcpython-9a45bfe6f4aedd2a9d94cb12aa276057b15d8b63.tar.gz
cpython-9a45bfe6f4aedd2a9d94cb12aa276057b15d8b63.tar.bz2
cpython-9a45bfe6f4aedd2a9d94cb12aa276057b15d8b63.zip
bpo-35569: Expose RFC 3542 IPv6 socket options on macOS (GH-19526)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 68fc3120cc..0f92a9c010 100644
--- a/setup.py
+++ b/setup.py
@@ -1116,8 +1116,12 @@ class PyBuildExt(build_ext):
def detect_socket(self):
# socket(2)
if not VXWORKS:
- self.add(Extension('_socket', ['socketmodule.c'],
- depends=['socketmodule.h']))
+ kwargs = {'depends': ['socketmodule.h']}
+ if MACOS:
+ # Issue #35569: Expose RFC 3542 socket options.
+ kwargs['extra_compile_args'] = ['-D__APPLE_USE_RFC_3542']
+
+ self.add(Extension('_socket', ['socketmodule.c'], **kwargs))
elif self.compiler.find_library_file(self.lib_dirs, 'net'):
libs = ['net']
self.add(Extension('_socket', ['socketmodule.c'],