aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.azure-pipelines/docs-steps.yml2
-rw-r--r--.github/workflows/doc.yml2
-rw-r--r--.travis.yml2
-rw-r--r--Doc/Makefile1
-rw-r--r--Misc/NEWS.d/next/Documentation/2020-11-24-22-54-49.bpo-42238.62EOTu.rst2
5 files changed, 5 insertions, 4 deletions
diff --git a/.azure-pipelines/docs-steps.yml b/.azure-pipelines/docs-steps.yml
index eaf4ad01927..55c38611b95 100644
--- a/.azure-pipelines/docs-steps.yml
+++ b/.azure-pipelines/docs-steps.yml
@@ -16,7 +16,7 @@ steps:
displayName: 'Install build dependencies'
- ${{ if ne(parameters.latex, 'true') }}:
- - script: make check suspicious html PYTHON=python
+ - script: make check html PYTHON=python
workingDirectory: '$(build.sourcesDirectory)/Doc'
displayName: 'Build documentation'
diff --git a/.github/workflows/doc.yml b/.github/workflows/doc.yml
index 7c6012eed4f..f0dbfcd9d3b 100644
--- a/.github/workflows/doc.yml
+++ b/.github/workflows/doc.yml
@@ -36,7 +36,7 @@ jobs:
- name: 'Install build dependencies'
run: make -C Doc/ PYTHON=../python venv
- name: 'Build documentation'
- run: xvfb-run make -C Doc/ PYTHON=../python SPHINXOPTS="-q -W --keep-going -j4" doctest suspicious html
+ run: xvfb-run make -C Doc/ PYTHON=../python SPHINXOPTS="-q -W --keep-going -j4" doctest html
- name: 'Upload'
uses: actions/upload-artifact@v2.2.0
with:
diff --git a/.travis.yml b/.travis.yml
index 254a4ea35ab..dfdf670bff5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -53,7 +53,7 @@ matrix:
- cd Doc
- make venv PYTHON=python
script:
- - make check suspicious html SPHINXOPTS="-q -W -j4"
+ - make check html SPHINXOPTS="-q -W -j4"
- name: "Documentation tests"
os: linux
language: c
diff --git a/Doc/Makefile b/Doc/Makefile
index 6bf1f408b56..c24c70c699a 100644
--- a/Doc/Makefile
+++ b/Doc/Makefile
@@ -216,7 +216,6 @@ serve:
# for development releases: always build
autobuild-dev:
make dist SPHINXOPTS='$(SPHINXOPTS) -Ea -A daily=1'
- -make suspicious
# for quick rebuilds (HTML only)
autobuild-dev-html:
diff --git a/Misc/NEWS.d/next/Documentation/2020-11-24-22-54-49.bpo-42238.62EOTu.rst b/Misc/NEWS.d/next/Documentation/2020-11-24-22-54-49.bpo-42238.62EOTu.rst
new file mode 100644
index 00000000000..d9edf9cdf79
--- /dev/null
+++ b/Misc/NEWS.d/next/Documentation/2020-11-24-22-54-49.bpo-42238.62EOTu.rst
@@ -0,0 +1,2 @@
+Tentative to deprecate ``make suspicious`` by first removing it from the CI
+and documentation builds, but keeping it around for manual uses.