aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2020-02-10 00:52:50 +0000
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2020-02-10 01:03:54 +0000
commite9644c20ce4718ca99953cab0d306b7789303c8e (patch)
tree89e57ee542ffff864375f9631e4301bbea3991ea /htl
parenthtl: Make sem_open return ENOSYS (diff)
downloadglibc-e9644c20ce4718ca99953cab0d306b7789303c8e.tar.gz
glibc-e9644c20ce4718ca99953cab0d306b7789303c8e.tar.bz2
glibc-e9644c20ce4718ca99953cab0d306b7789303c8e.zip
htl: Make sem_wait/sem_timedwait interruptible
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/pt-internal.h8
2 files changed, 10 insertions, 0 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 1b33748934..39294c64d1 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -108,6 +108,8 @@ libpthread-routines := pt-attr pt-attr-destroy pt-attr-getdetachstate \
\
pt-block \
pt-timedblock \
+ pt-block-intr \
+ pt-timedblock-intr \
pt-wakeup \
pt-docancel \
pt-sysdep \
diff --git a/htl/pt-internal.h b/htl/pt-internal.h
index 8ffe1bd970..918c207c3e 100644
--- a/htl/pt-internal.h
+++ b/htl/pt-internal.h
@@ -270,6 +270,14 @@ extern error_t __pthread_timedblock (struct __pthread *__restrict thread,
const struct timespec *__restrict abstime,
clockid_t clock_id);
+/* Block THREAD with interrupts. */
+extern error_t __pthread_block_intr (struct __pthread *thread);
+
+/* Block THREAD until *ABSTIME is reached, with interrupts. */
+extern error_t __pthread_timedblock_intr (struct __pthread *__restrict thread,
+ const struct timespec *__restrict abstime,
+ clockid_t clock_id);
+
/* Wakeup THREAD. */
extern void __pthread_wakeup (struct __pthread *thread);