aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSusant Sahani <ssahani@gmail.com>2018-11-26 17:20:09 +0530
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-11-27 11:04:42 +0900
commit2266864b04257d7a92d1f2064797ec239068895b (patch)
tree6aa37cde244d083bb2ce2c3b7060dd423b3a03c8 /meson.build
parentFirst restructuration of Logitech mice in 70-mouse.hwdb (diff)
downloadsystemd-2266864b04257d7a92d1f2064797ec239068895b.tar.gz
systemd-2266864b04257d7a92d1f2064797ec239068895b.tar.bz2
systemd-2266864b04257d7a92d1f2064797ec239068895b.zip
networkd: Add support for ERSPAN tunnel
Please see: https://patchwork.ozlabs.org/patch/800327/ ``` [NetDev] Name=erspan-test Kind=erspan [Tunnel] Independent=true ERSPANIndex=123 Local = 172.16.1.200 Remote = 172.16.1.100 Key=101 SerializeTunneledPackets=true ```
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5dc25d03d..8b51d032b 100644
--- a/meson.build
+++ b/meson.build
@@ -464,6 +464,7 @@ foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IFLA_VTI_REMOTE', 'linux/if_tunnel.h', '#include <net/if.h>'],
['IFLA_IPTUN_ENCAP_DPORT', 'linux/if_tunnel.h', '#include <net/if.h>'],
['IFLA_GRE_ENCAP_DPORT', 'linux/if_tunnel.h', '#include <net/if.h>'],
+ ['IFLA_GRE_ERSPAN_HWID', 'linux/if_tunnel.h', '#include <net/if.h>'],
['IFLA_BRIDGE_VLAN_INFO', 'linux/if_bridge.h'],
['IFLA_BRPORT_PROXYARP', 'linux/if_link.h'],
['IFLA_BRPORT_LEARNING_SYNC', 'linux/if_link.h'],